BMW ConnectedDrive component

Same here as of yesterday/today

1 Like

Hello,

Same on my side. I had created an automation to update the parameters of my car, but it never really worked (error NOT_FOUND 404 in the HA logs, but today it’s UNKNOWN_ERROR code 400).
I don’t know if I’m going wrong with its configuration, which was not complicated, but it doesn’t seem very stable on a daily use.

Config

 bmw_connected_drive:
  bmw:
    username: !secret USERNAME_BMW_CONNECTED_DRIVE
    password: !secret PASSWORD_BMW_CONNECTED_DRIVE
    region: rest_of_world
    read_only: false

Automation

- alias: BMW - Update
  description: BMW Connected Drive update Info
  trigger:
    platform: time_pattern
    hours: '/4'
  action:
    service: bmw_connected_drive.update_state

Lovelace pic:
2020-02-14 22_23_44-Window

I came here to see if I could get a fix for this, good to hear it’s not only me having problems and I’ll just have to be patient.

There’s a suggestion on the site for the bimmer_connected component that BMW have changed the name of the server used for retrieving the OAuth credentials.

I suspect it may be as simple as changing the definition of AUTH_URL in
/usr/local/lib/python3.7/site-packages/bimmer_connected/const.py
to point at
'https://customer.bmwgroup.com/gcdm/oauth/authenticate'
but I don’t have a setup on which I can easily patch this in at present.

If I get some time later this weekend I’ll try and experiment, and submit a PR upstream; it may be a little while before that reaches us, though, if it works.

Anyone got a good way of monkey-patching this value in a running Home Assistant to try out?

I will try at soon I come to my system. I will create a custom component and try it then. Today late afternoon

There’s an update on that bimmer_connected issue which suggests it probably needs a bit more than that. But it shouldn’t be too hard to get working again.

I was not able to make it work. seems we need to wait till the bimmer connected package is updated

Confirming I’m having the same config issue, has been working flawless for months then from Saturday 15/02/20 invalid config.

bmw_connected_drive:
bmw:
username: !secret USERNAME_BMW_CONNECTED_DRIVE
password: !secret PASSWORD_BMW_CONNECTED_DRIVE
region: rest_of_world

not sure if it’s a issue with BMW servers or a change they made, or the latest version of HA 0.105.4

Keen on finding a fix as I use this integration a lot.

Frenck on github i’m aware is pretty clued up on the BMW connected drive integration, perhaps may be worth reaching out to him.

Can anyone on a lower version confirm they are getting the same? It seems like it is integration related not HA version but would be nice to confirm

Did you mena HA version or bimmer_connected? I’m on 0.105.2 of HA and I have the same problem. Not sure if that is far enough back to be of use

HA version but according to https://github.com/bimmerconnected/bimmer_connected/issues/150 it’s not HA, BMW changed the connection url it seems.

If it’s not working on 0.105.2 then it’s most likely BMW side, as mine worked previously on HA 0.105.2 , 0.105.3 - with 0.105.4 I think it must of been purely coincidental that I upgraded during the same time BMW changed something.

This is caused after BMW made a change to their API (so has nothing to do with a HA version).

PR is made -> https://github.com/home-assistant/home-assistant/pull/31894.
The PR also fixes the maxFuel issue mentioned in some posts.

@gerard33 thank you for the fix.
I’ve copied the code from github and created a costum component for the time being. And it is working again.

1 Like

Thanks. Since 0.105.5 doesn’t appear to be scheduled, I’ve updated both files manually in my docker container:
/usr/src/homeassistant/requirements_all.txt
/usr/src/homeassistant/homeassistant/components/bmw_connected_drive/manifest
to reflect version 0.7.0
In case someone else like me can’t wait for 0.106.0

ah, that’s even a better way then my idea… I will change it as well. becaus I cannot wait till the next version :slight_smile:

1 Like

done nothin, working again…

1 Like

Same, works out of the blue, nothing changed, on 0.105.4

1 Like

Confirmed ! It’s working again for me.

Working OK for me too, just rebooted HA.

Perhaps BMW had a change of heart and rolled out an update?