Broadlink error preventing component from loading - incorrect pycrytodome version

Hi All,

I did a restart via the config menu this morning and HA takes about 15mins to load up. The only new thing I see in the log is this relating to Broadlink. Everything was working before the restart. HassIO 0.80.2

2018-10-29 07:07:07 ERROR (SyncWorker_4) [homeassistant.util.package] Unable to install package broadlink==0.9.0: Failed building wheel for pycryptodome
broadlink 0.9 has requirement pycryptodome==3.4.11, but you’ll have pycryptodome 3.7.0 which is incompatible.
python-jose-cryptodome 1.3.2 has requirement pycryptodome<3.4.0,>=3.3.1, but you’ll have pycryptodome 3.7.0 which is incompatible.
Command “/usr/local/bin/python3 -u -c “import setuptools, tokenize;file=‘/tmp/pip-install-mrml5ioo/pycryptodome/setup.py’;f=getattr(tokenize, ‘open’, open)(file);code=f.read().replace(‘\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /tmp/pip-record-36dvm2ib/install-record.txt --single-version-externally-managed --prefix --compile --user --prefix=” failed with error code 1 in /tmp/pip-install-mrml5ioo/pycryptodome/
You are using pip version 18.0, however version 18.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.
2018-10-29 07:07:07 ERROR (MainThread) [homeassistant.requirements] Not initializing switch.broadlink because could not install requirement broadlink==0.9.0
2018-10-29 07:07:07 ERROR (MainThread) [homeassistant.setup] Unable to prepare setup for platform switch.broadlink: Could not install all requirements.

Just upgraded to 0.81.0 and have the same problems

bumping this as a few people seem to have the same issue and we are desperate for assistance… please!

Yes it takes a while to restart, once it is restarted, is it causing all that much grief?

yes, as per the error message in the log I posted above, none of my Broadlink switches work since the Broadlink component fails to load. I really should have put that as the main part of the title

I think this needs elevating to github as there is a clear dependency problem.

that last time I tried submitting a PR I was told I f**ked it up so I left it be. Obviously I did it wrong… Is there a tutorial somewhere to explain the correct way to do it?

submit an issue… not a PR - go to issues and add an issue

what he said…

to the main Home Assistanrt repo?

I suggest going to the component in the dock and then in the upper right you’ll see the py file… click on that and then look for the issues tab
image
image

and it’s going to the main HA anyway…

thanks. I had a look and its already been reported on there

you should make a comment as well there…

done. Cheers guys.

I had the same problem which related to my broadlink media player custom component. I just deleted the file downloaded the latest version from the github page and reinstalled and it all worked fine

Deleted which file? Downloaded the latest version of what?

My broadlink media player custom components which are in the custom components folder. Deleted whole file (for me was media player) and re downloaded from github.

It took out whole broadlink component. I had not made any changes or upgrade apart from configuring my router in the new Upnp/idg components. Not sure that made a difference but deleted that config too and rebooted and all came back

I just tried swapping the contents of the broadlink.py files from within the custom_components with those of the Git pages however it made no difference. To be honest I was sure it wouldn’t fix the issue given that those Git files haven’t been updated in over 4 months… So the problem persists

Did you delete the cache file as well? I deleted both. Sounds like it might not be the issue anyway but worth a try. Hope you get it sorted.

Have you downgraded back to an earlier version to see if that solves the problem

where is the cache file in HA?