Broadlink IR Climate Component


I’ll have to dig a bit. Whenever I use a similar command, if the system is off, Google reports " That mode is not available for the Air-Conditioner"


Have you performed a sync with google since last making changes? Got your config handy?


All has just recently been synchronised.

I’ve had the broadlink device setup for about 3 months, but have only just got around to setting up the cloud component and Google Assistant linking in the last week.

I’ll have to dig a bit on my end and see what is going on :slight_smile:


Ahh ok. I’m not using cloud with my setup but I don’t see it being any different. It does sound like something with assistant rather than the broadlink component though.


Quite possibly. I’ll dig deeper :slight_smile:



I have an AC from Mitsubishi !

I use this file

But it doesn’t have the auto mode in it :frowning: How can I scan the codes to add the file?


Create a new section and add each code, like this:


auto_16 = <code>

You will need to use the learn_command service call, for all variations of auto (e.g. 16-30 degrees).

You will then need to add the new operating mode to the component.


Having the same problem as you, Google say’s it’s off, and whenever i try voice commands i get “that mode isn’t available for Heat Pump”
Let me know if you figure it out:-)


I have had no luck at all getting this to work.
When using the official, cloud based integration of Google Assistant, it does not work.
It seems to be an issue with the customer component.
It may work with the local voice assistant, and that’s fine for those that want to do that, but it does not work with the official Google integration for on, off or mode changes.

Any ideas on how to make it work with the official integration with Google Assistant ( not local voice assistant ) would be most welcome.


You’ve gone through this page for setup?


No offence meant here, but the Google assistant set up is not an issue. The assistant can control the temperature fine when the A/C device is on. It just can not change modes or turn the A/C on if it is off. It sees the device fine, it specifically says "That mode is not available for the [insert name of device here] ".
As I said earlier, the Google Assistant works perfectly with the ZXT-120 Z-wave to IR device.
In fact, Google Assistant controls everything fine, excepting this component.

The reason for using the Broadlink device was because the ZXT-120 has it’s own issues with OpenZwave, which are well documented in forums.

Given someone else is reporting the exact same issue with the mode not being available, it does look like it is based around the way the component is written. I know it is a custom component and not official, so it is great that it works as it does.

I’ll just have to work on writing scripts to perform the functions that the component is missing.

Thanks for the assistance. :slight_smile:


None taken. :slight_smile:

So as I’d mentioned in a previous post, I tried your voice command exactly again just now, “Hey google, turn on the cooling at 26 degrees”. This responded with “Sure, turning on the Living Room AC to 26 degrees.” then proceeded with suggesting some night time modes.

BTW I have two instances of this component running, my Living Room and Master Bedroom.

I then commanded “Hey google, turn off the Living Room AC” and it succeeded.

FYI I have both LG split systems and the LG.ini IR codes in this component were recorded by me.


Just a quick question.
Are you using Hassio?


Yes, latest 0.81.0. Google Assistant component (manual, not cloud) and this broadlink component.


I might try the manual assistant as a test, but prefer the cloud for Google as I can use it remotely.

I am guessing there may be a difference between the cloud and manual integrations


I can use It remotely too with the manual integration. I’m not sure if there is much difference between the two.

Does your AC appear as a thermostat in Google Assistant home control?


It appears to show up exactly the same as the ZXT-120 does, as a thermostat.

I have a couple of spare SD cards. I will try building a fresh ‘test’ version and see how that goes.


Hi @Vassilis , this component has been working great for me for months and I want to say thank you for that, however after a HA restart today it stopped working and is giving me the below in the log. Any ideas what I can do to fix it?

2018-10-29 08:28:35 ERROR (SyncWorker_2) [homeassistant.util.package] Unable to install package broadlink==0.9.0: Failed building wheel for pycryptodome
broadlink 0.9 has requirement pycryptodome==3.4.11, but you’ll have pycryptodome 3.7.0 which is incompatible.
python-jose-cryptodome 1.3.2 has requirement pycryptodome<3.4.0,>=3.3.1, but you’ll have pycryptodome 3.7.0 which is incompatible.
Command “/usr/local/bin/python3 -u -c “import setuptools, tokenize;file=’/tmp/pip-install-a4wu3drs/pycryptodome/’;f=getattr(tokenize, ‘open’, open)(file);’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /tmp/pip-record-h2dxwrs0/install-record.txt --single-version-externally-managed --prefix --compile --user --prefix=” failed with error code 1 in /tmp/pip-install-a4wu3drs/pycryptodome/
You are using pip version 18.0, however version 18.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.
2018-10-29 08:28:35 ERROR (MainThread) [homeassistant.requirements] Not initializing switch.broadlink because could not install requirement broadlink==0.9.0
2018-10-29 08:28:35 ERROR (MainThread) [homeassistant.setup] Unable to prepare setup for platform switch.broadlink: Could not install all requirements.

I have a feeling it is an overall Broadlink issue rather than just your custom_component but I’m not sure. I also use your Broadlink media_player and that is also not working


did you find a solution to this? I have the same situation


Same for me…