Broadlink pro "Failed to connect" issue

I’m new to HA (first post) and having trouble getting HA to talk to my Broadlink rm pro plus.
*I reserved the DHCP address.
*triple checked the RM pro IP & MAC address
increased timeout to 60
added Type: rm2_pro_plus
my ihc and e-control app can talk to the device but
still when i send my switch.broadlink_learn_command_192_168_
_

nothing… continue to see: “Failed to connect to device” Error log.

switch:

  • platform: broadlink
    host: 192.168..
    mac: ‘:::::
    type: rm2_pro_plus
    timeout: 60

i’m out of ideas any helped would be appreciated. Thanks

not sure if this is an issue but i do have duckdns and portforwarding set up set up.
as all that should be external i didn’t give it any thought. but
when i try to browse to my HA IP @:8123 i get nothing i have to use the XXX.duck.dns.org url.

Are you sure the ip address and the mac address is the correct one for the broadlink device?

Yes unfortunately i’ve checked my router over and over. i even made the IP address static

Then there is something that blocks the connection between your HA computer and the Broadlink device.
Check the firewall. Both on your router and HA computer.

Thanks for the replies!
i’ve checked the router settings and nothing there should be blocking it.
as for HA i’m using the resinos-hassio-1.1-raspberrypi3.img.bz2 flashed on a pi3
and am unformiliar with how to check the network/firewall setting for an issue on this device

Update i am able to internally communicate with the broadlink pro now and receive switch packets!
Unfortunately, to get this to work i had to uninstalled DuckDNS and deleted my port forwarding rules.
I’m new to DDNS does anyone know why with was interfering with my internal routing? And if there is a work around to this? Thanks

Did you ever get this settled?

I have a similar problem: my RM Pro + can’t be configured. Fails repeatedly. Even after I connect the phone to the BoadlinkProv wifi network. Is there any help on this?