Broadlink RM pro learn RF command error

Not sure starting which verion remote learn can only learn IR command.
Anyone got same issue?

Mine’s OK. The drop down list allowing you to select RF only appears when you tick the box on the right…

Assuming you have a Broadlink Pro, of course…

Yes. I’m using Broadlink Pro. But when I select RF. Brodlink will not light up the yellow indicator.
If select IR, it will.

I don’t think the light does flash when you learn RF commands - you get instructions via HA notifications.

When you issue the remote.learn command, first you’re told to press and hold the button on the remote while the Broadlink scans frequencies, then you’re told to release the button and press it once quickly. I found it worked better if I held the remote quite close to the Broadlink.

Thanks for the reply. But I belive RM pro should show yellow light when learn command.
Have your tried with the newest HA version?

Anyone can help?

When I using below service to learn rf command

service: remote.learn_command
  entity_id: remote.broadlink_living
  device: testfan
  command_type: rf
  command: 'on'

I got error in logs

Logger: homeassistant.components.broadlink.remote
Source: components/broadlink/
Integration: Broadlink (documentation, issues)
First occurred: 22:30:04 (1 occurrences)
Last logged: 22:30:04

Failed to learn 'on': [Errno -4] Command not supported