Broken plug 1 day after flashed with Tasmota?

Hello,
I tried to flash some Gosund SP1 sockets with tuya-convert, which worked fine so far with 3 of 10 devices.
However, as I´m playing around with Tasmota, HA and MQTT, i noticed that 1 socket won´t turn on anymore. I can access it from the Tasmota Webinterface, and can also toggle on and off, but the socket does not make the “switching click”. Strange that it was workiing yesterday when I flashed it

Is there a possiblity that i could be bricked because of Tasmota, or could it be just a coincidence? I guess there is nothing I can do with this socket anymore?

Thanks,
Phil

Unlikely to be caused by Tasmota.

First check that the correct gpio are still being assigned. If so, then…

You could try re-flashing it with Tasmota, or the original firmware. Tuya convert saves a copy before converting. I have no idea where though. You may have to research this.

If none of that works - warranty claim.

I m better quitting it all. I tried the next socket, and it has the same issues - I can’t turn it on through the hardware button nor put it into pairing mode for another try.

2 out of 4 bricked (although I can reach them both with webinterface - But I don’t want to lose my other working ones :frowning_face:

Sounds very like you do not have the correct Tasmota template / device specified and once you do they will operate as you expect.

Which template are you using?

According the the docs you should be configuring Tasmota this way:

There are several clones of this device – use the Teckin device:

  • Gosund SP1 (Version 2.3 and 2.4)
    • To configure select Gosund SP1 v23 (55) or console command Module 55
  • BlitzWolf SHP2 (Version 2.3 and 2.4)

See: Gosund SP1 - Tasmota

I have the same template specified like the 2 working sockets: “Gosund SP1 v23 (55)”, as they are all Gosund SP1. However, they all have been bought between 2018 and 2019, so I don’t know if they have all the same Hardware version.

I tried some generic templates and GPIO Settings, but since I started with Tasmota 2 days ago, I’m not quite familiar with it all.

Do I have to test some other device templates?

Thanks, I’ll look into into right away

You could try the BlitzWolf SHP2.

I love you, man. Thanks a lot. I was about to throw them out of the window.

1 Like