BRUH DIY Multisensor

So I also used the BRUH automation script as a base for my sensors. I ended up hiding it a little differently though. I built this out of some steel I had around. I hid the node in the head, sensors mount on the sides of his head. Not done yet, but working on it.

4 Likes

Any one else getting this error?
Invalid config for [light.mqtt]:[flash] is an invalid option for [light.mqtt].

Any ideas on how to fix it? Im getting the same error on my BRUH led strip

I had that with 0.87.0 so I just removed it from the MQTT config. Per the docs flashing is not supported with the light MQTT schema.

Cheers. I did just comment it out and it seemed ok.

I set this up last saturday with esphome and it was super easy. Took me around 10 minutes after i understand what to do.
I also had trouble with a lot of my zigbee2mqtt devices and ended up deleting them and used mqtt autodicovery to add them again.

Hi everyone, i find the Bruh pir sensor is very short range, so i wonder if the RCWL-0516 radar motion sensor will work with this build?

i’ve ordered the components for this project except the enclosure. I think i’ll try my luck with a pringles enclosure and see how it goes.
Are still BRUH’s instructions valid or is there any updated version (or better alternatives) for hassio?

Hey, just built this project, but before I add it to HA, I’m wondering: is there any way to make it work with HA auto discovery? Autodiscovery works perfectly with my Tasmota-flashed sonoffs, I’d love to do the same with these.

Or, for that matter, can I just flash it with Tasmota? That’d be ideal. If so, what’s the procedure (can it be done OTA?) and configuration needed?

Use https://esphome.io for this. Works great!

There even is a recipe for Bruh’s multisensor

I just built 4 of these. I ordered the exact DHT22 sensor recommended in BRUH’s video
video: https://www.youtube.com/watch?v=jpjfVc-9IrQ&feature=youtu.be&t=464
DHT22: shortened link
I used the code provided by BRUH as well (modified only the network and MQTT info)
Got the DHT library from here: https://github.com/adafruit/DHT-sensor-library
verified this is the same code provided BY the sensor’s page

All 4 devices are reporting 50F when its ~70F. They don’t seem to fluctuate much, even as the actual temperature dips down to 50F, the reported stays between 50F and 53F (with about 5 spikes per day when it will randomly report between 0-10F for a single tick)

Most of them also report 30% humidity when it is actually >70. Breathing on it brings it up to about 33% after a few minutes. One of them was reporting 3000%+ Humidity. I’m not sure if it still is as it was given to a friend.

I have resecured the cord several times, restarted several times, and tried several power sources and am at a loss as what to try next.

The light and motion sensors also attached to the ESP8266 are both reporting correctly. It’s just these 4 DHT22!

note: I have tried this both in and out of the 3D printed case, same result. (I saw some people were blaming incorrect temps on bad airflow)

Roll back to an older version of the DHT library. That should fix you up.

1 Like

Thanks I’ll give that a shot when I get home.
Any idea how far back I should try?
I guess worst case, I’ve only got 11 other versions to try.

I’d like to say 1.1.0 but I don’t recall off the top of my head.

1 Like

“Roll back to an older version of the DHT library. That should fix you up.”

1.1.0 seems to have done the trick! Temp is spot on. Humidity still seems a bit low imo (still 30, compared to 70 upstairs) but blowing on it spikes it right up to 99% so at the very least, its responsive!

Maybe you have a water leak upstairs? :stuck_out_tongue: