CalDav don't accept any add

Hi,
I’m trying to add one or more CalDAV, but I always run into errors.
I’ve checked about iCloud, but the fact is I use a public calendar anyway for this, so it’s fully accessible. I made sure to use https instead of webdav.
But, as it’s required to use a username, and it was not working with random strings, I’ve tried another way, getting a PHP page on my website that will just return the original content. But here, same error.
I’ve tried then to secure this folder with a username and password, but got same error again.
Any idea?

Enregistreur: homeassistant.components.caldav.config_flow
Source: components/caldav/config_flow.py:71
intégration: caldav (documentation, problèmes)
S'est produit pour la première fois: 15:57:52 (4 occurrences)
Dernier enregistrement: 16:44:32

Unexpected exception
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/caldav/config_flow.py", line 71, in _test_connection
    await self.hass.async_add_executor_job(client.principal)
  File "/usr/local/lib/python3.12/concurrent/futures/thread.py", line 58, in run
    result = self.fn(*self.args, **self.kwargs)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.12/site-packages/caldav/davclient.py", line 425, in principal
    self._principal = Principal(client=self, *largs, **kwargs)
                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.12/site-packages/caldav/objects.py", line 506, in __init__
    cup = self.get_property(dav.CurrentUserPrincipal())
          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.12/site-packages/caldav/objects.py", line 224, in get_property
    foo = self.get_properties([prop], **passthrough)
          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.12/site-packages/caldav/objects.py", line 256, in get_properties
    properties = response.expand_simple_props(props)
                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.12/site-packages/caldav/davclient.py", line 298, in expand_simple_props
    self.find_objects_and_props()
  File "/usr/local/lib/python3.12/site-packages/caldav/davclient.py", line 221, in find_objects_and_props
    responses = self._strip_to_multistatus()
                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.12/site-packages/caldav/davclient.py", line 157, in _strip_to_multistatus
    if tree.tag == "xml" and tree[0].tag == dav.MultiStatus.tag:
       ^^^^^^^^
AttributeError: 'NoneType' object has no attribute 'tag'

Thanks