Can connect from iPhone but not from computer

Hello.
I’ve just started evaluating Home Assistant, and have installed it on a RPi3 and connected to my home network via Ethernet. And now I’ve struggled for a while with connecting to the RPi3 from my computer. I’m not able to use neither hassio.local:8123 nor :8123. However, when I tried it on my iPhone, both addresses worked like a charm. I’ve tried disabling both firewall and antivirus, but no difference there.

Should there be any difference in using a web browser on an iPhone vs on a Windows computer to connect to the RPi3 server?

Is your desktop web browser attempting to connect via http://hassio.local:8123 or https://hassio.local:8123 (note the ‘s’).
Unless you have DuckDNS installed you should specify http.

Try with the IP address. Name resolution of .local names is not DNS but mDNS (Avahi, Bonjour), support on client OS is different.

I’m using http both on my phone and computer. Have not yet enabled ssl. On my phone both IP and hassio.local works fine, but on my computer neither work.

Also, my computer does have a working internet connection, and is connected to the same router (same switch, in fact) as the RPi3.

What do you mean by “doesn’t work”? Do you get a timeout, a connection refused, a white page, an error 404 or 500, a spinning wheel?

Ah, I apologize for being unclear. When trying http://hassio.local:8123 on my computer, I get an error that the host is not found. I’m not able to ping it either. However, now http://ip:8123 on my computer does work, actually. On my iPhone both hassio.local:8123 and ip:8123 works.

I am curious why I’m able to resolve hassio.local on my iPhone but not on my computer though.

Windows doesn’t have a native implementation of mDNS.

1 Like

Aaah, now there’s your problem! :slightly_smiling_face: Turns out then that the solution, at least for me who owns an iPhone, was to install iTunes. iTunes comes bundled with Bonjour, Apples zeroconf client also implementing mDNS. Problem solved.

Thank you for your help! :slightly_smiling_face:

1 Like

Ha. I just got a popular link badge for 50 clicks on the http://hassio.local:812 link I posted above.

I hope it’s bots and not idiots.

Yup this instantly worked for me! so weird lol