Can not install Add-ons HASSIO

HI, After install Hass.io on VM withing Proxmox, i was able to install add-ons: MQTT, Samba Share and SSH. After installing this and migrating my files from the Raspi to the VM i can not install anymore add-ons. For example: I can choose a add-on ( PIHOLE) from this repository ( https://github.com/hassio-addons/repository ), the insall button will highlight red for a couple of seconds and then fade away. Nothing installs. Anyone have a fix for this?

I’m having the same issue. Have you found a fix?

Unfortunately no I havnt. As you can see I’m not getting much help. I think the best bet is to reinstall Hass.io and start over.

Check the supervisor logs for errors at http://hassio.local:8123/hassio/advanced. My guess is you might be out of disk space.

This is what i get…

Attempt to install an add-on then click on view logs on that page.

17-12-13 00:07:36 INFO (SyncWorker_9) [hassio.dock.interface] Pull image homeassistant/amd64-addon-google_assistant tag 0.0.3-p5.
17-12-13 00:07:36 ERROR (SyncWorker_9) [hassio.dock.interface] Can’t install homeassistant/amd64-addon-google_assistant:0.0.3-p5 -> 500 Server Error: Internal Server Error (“Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:47268->[::1]:53: read: connection refused”).

That looks like you’ve got DNS issues on your host.

1 Like

im just routing through Pihole which is installed on a Raspi.

You sir are a genius , added my DNS server info to the linux interface config file and all good now !! Thanks!

2 Likes

How do you do this?

SSh into your host machine, and follow this

could not install any add on. This is the error im getting --------18-08-07 11:54:44 INFO (SyncWorker_2) [hassio.docker.interface] Pull image homeassistant/armhf-addon-configurator tag 1.1.
18-08-07 11:54:59 ERROR (SyncWorker_2) [hassio.docker.interface] Can’t install homeassistant/armhf-addon-configurator:1.1 -> 500 Server Error: Internal Server Error (“Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)”).---------

Could anyone help me out with this

I too was getting the same issues and it was very frustrating. I could not install add-ons and I could not update Hass.io to the newer versions.

After mush searching, this post gave me the idea of manually adding the Google DNS nameservers to my Raspberry Pi. When I rebooted my Pi the settings were gone.

From the command line of my Hass.io Pi, I tried pinging www.google.com and what I got returned indicated that my Pi was using an IPv6 address. This was strange because IPv6 is disabled throughout my network (or so I thought).

My IOT devices (and Hass.io) are in a completely different network behind their own router which is connected to an interface of my main router/firewall. My main firewall does not use IPv6 at all. Checking the IOT networks router, I discovered that IPv6 was enabled for DHCP clients. I disabled this and rebooted my Pi.

First test was to ping www.google.com - this worked perfectly.
Next tried to update Hass.io - worked perfectly.
Final test - installed an add-on - worked perfectly.

This worked for me, give it a try and see if it worked for you.

RE

I had the same issue this morning. I suspect after removing the depreciated Pihole addon, it might have done something strange with my DNS entries. Anyway…

Open the terminal window to your HASSIO linux build (18.04 LTS in my case).
ping google.com
If unsuccessful, then run the following:

unlink /etc/resolv.conf
nano /etc/resolv.conf

nameserver 8.8.4.4
nameserver 8.8.8.8

Save the file Ctrl O, then exit CTRL X
ping google.com
apt update
apt install resolvconf
systemctl status resolvconf.service
systemctl enable resolvconf.service
systemctl start resolvconf.service

This worked for me, hopefully it helps someone else.

so i have a similar issue - cannot load any add-ons getting this message:
ERROR (SyncWorker_1) [supervisor.docker.interface] Can’t install homeassistant/aarch64-addon-configurator:5.2.0 -> 500 Server Error for http+docker://localhost/v1.40/images/create?tag=5.2.0&fromImage=homeassistant%2Faarch64-addon-configurator: Internal Server Error (“Get “https://registry-1.docker.io/v2/”: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)”).

i have ha loaded on a raspberry pi400 booting off of an SSD drive.

i initially started on my home network - got to sign in and shut it down - plugged pi into my brother’s network - system starts - finds some integration items, but will not allow for add ons -