Can you get a live rtsp stream?


#21

ok, but actually, my rtsp stream from synology is smooth, its just the ffmpeg platform in HA that isnt smooth
what is your code to embed an rtsp stream? because i used the ffmpeg platform
maybe i cam embed it too? but then use the rtsp stream from synology?


#22

I tried that already… it wasn’t smooth for me at all (from synology), but then again I have (6) 4 megapixel cameras running at 30 fps at the same time… the only way I could get a good stream was from the embed url from motioneye… directly from synology didn’t work for me (after spending $200 on licenses which didn’t work). My synology is under powered (1812+ with 3 gigs of ram and 16 tb of space used mostly for customer backups). I even have motioneye using webhooks into HA for motion sensing (still tweaking it), but it catches motion instantly and turns my outside lights on in 200 to 300 ms


#23

well, i can try , i run synology virtually on a esxi server (xpenology)
using uhhmm not a valid license :slight_smile:
how do you embed an rtsp stream?


#24

In a card you can’t, that will only take an http url. xpenology is legal (from the synology open source), but it is not stable (I know, I had a lot of problems with it). Install motioneye in ubuntu 18 in a VM and don’t look back. Trust me you won’t be sorry.


#25

well, i am running xpenology for over 4 years now, i like it verry much, for me its stable
just dont update as to a higher level, so bootlader 6.1 , stay on 6.1 :slight_smile:
i really like the features from Surveillance:

  • home mode
  • timeline view, (see recorded videos from different cameras in one easy timeline view)

i dont know if thats possible with motioneye?


#26

don’t stop using Surveillance Station… I’m still using it for recordings, just install motioneye for the embed url… that’s what I did… (besides wanting to test the motion setup for HA). Last time I tried xpenology was 5.1, so I’m sure there were issues, but I have an actual synology unit so I don’t worry about it anymore (stability).


#27

Ah ok, clear :wink:

Gonna test that motioneye add-on tomorrow :wink:

Thnx for info


#28

actually, just thought about it… if you can use docker in xpenology, install motioneye there… you can do a quick test, but I don’t know what kind of resources your VM has…


#29

Yeah, gonna play with it :wink:


#30

Hmm, I get camera rtsp stream running in Lovelace UI, but did not find a way how to run it under MotionEye Hassio add-on
Anybody could advice?


#31

put the rstp in the URL under network camera.

motioneye


#32

If I enter rtsp://my_login:[email protected]/1 to URL field, Username and Password once more in their fields, Camera field remains empty and cannot fill it.
If I press OK, nothing happens.
The same login works under Lovelace UI picture-entity w/o problems :frowning:


#33

go to https://www.ispyconnect.com/sources.aspx and get your specific link for your camera… it most all cases it won’t include login info in your url.


#34

Actually the specific link I have is from ispy.
I use the same to connect to my camera via ispy.


#35

what is the model of your camera?


#36

BESDER BES-6004MW-HXA201

Originally ispyconnect generated other link :
rtsp://my_login:[email protected]/user=admin_password=tlJwpbo6_channel=1_stream=0.sdp but with it ispy did not work.
Afterwards I searched net directly from ispy and it came (amongst other not working) with the one I am using now.
But in both are credentials embedded into the link.


#37

Odd stream url… the only stream I see under your manufacturer that looks logical to me is the one for 6024 model /h264_stream… did you try that one? i’d put it in like rstp://ip_address/h264_stream and see if you have access (if your camera is capable of h264). My cameras (hikvision) have multiple streams and I can select output streams.


#38

Hm, I gave it up with MotionEye.
Thank you anyhow :+1:


#39

No Problem.