Cannot save during onboarding initial setup

I have managed to download HA onto an old MacBook Pro (2011) running OS X Yosemite v 10.10.5. When I then go to the onboarding page, add a home name, detect my location (and moved it a bit as it was inaccurate), when I press Next I get the error message:
“Failed to save: Can’t find private variable: @derived constructor”
I am a complete IT baby. I assume I have probably got something wrong during the installation, but have no idea how to find what I did wrong.
Can anyone help?

Try manually setting it up:

Thanks Francis but same result / error message

How did you install HA ? Generic Linux install, docker or venv ?

Just to prove my lack of IT knowledge, I am not sure what the correct reply is. I followed the video on The Hook, adding directly to my Mac rather than using a Raspberry. I guess that means it was a generic Linux install.

Sorry, the video was from the Hook Up, not the Hook

Don’t use videos from youtube or guides from any other source than the official documentation. They are almost always outdated.

The macbook, are you planning to use it as your HA server and run it 24/7 or just for testing? I recommend getting a Pi and put it there to get started.

Thanks. The video was only about a month old, but you are correct - it was out of date in at least one regard.
Probably to be used for testing only, but if it does work ok, will try to run it 24/7 and see what happens. It will be in an area very prone to power cuts, so will be looking to add a generator and UPS to try to keep it going.

Can anyone else help with this error message?

Not exactly, but ‘failed to save’ would suggest either a permissions issue or a storage space issue, and I’d be inclined to believe it’s the former. Unfortunately I suspect from the earlier mention of a ‘lack of IT knowledge’ that’s not going to help you much.

Do you need addons? If not the installation instructions for Homeassistant Core on mac don’t appear particularly complicated…

Otherwise you’ll need to find someone who ‘speaks’ mac to help you set up the requirements correctly for a manual docker installation with correct permissions, which I can’t help you with unfortunately.

Thank you Marc. Will take a look at the guide and see if I can figure it out.

Just found this, that might suit you better. Bit more work but well explained I think.

It’s about the best I can do, other than suggest grabbing a raspberry pi for experimentation purposes :slightly_smiling_face:

Good luck :+1:

Thanks again Marc. The first suggestion pointed out a clear mistake on my part - had not installed Python. Did that, reinstalled, all looked good. Then, same problem. Will now try the second suggestion, or quite possibly go and get a Pi

1 Like

Tried the Vagrant version, but it failed it did not recognise the “vagrant up hassio” command. Think I have come to the end of my minimal skills. So Pi it will have to be. Really appreciate you trying to help - unfortunately I appear to be beyond help

1 Like

No worries - mac is, unfortunately, not the greatest for these sorts of things. Once you have a pi (or anything Linux based tbh) there will be tons of available options and tons of help for each. Even the most technical of problems you can normally be walked through line by line if needed.

The bonus of the raspberry pi approach is that it’s pretty much a one click install if you want to use the pi just for Homeassistant, so hopefully you’ll be up and running in next to no time :slightly_smiling_face:

1 Like

Ok, being a bit stubborn now. Still trying on my Mac. As far as I can tell now, following the instructions (at least as per the modified version on the post started by Erik Hendrix in Sep 2018), it all goes well until I get to the command:
hass --script macOS install
At this point, it seems to be looking in the wrong place. It is looking in
In my case, it looks like the the Library is in
Macintosh HD/
Not within the Users directory home assistant directory has been created in
Can’t figure out how to get the right files in all the right places, as Eric Morcambe nearly once said (apologies to non Brits or anyone less than 50 years old)

I don’t know much about mac file structure but the underlying basics are still Linux, so assuming macintosh hd is a top level folder then copying the files in there to your personal directory would be something like

sudo cp /Macintosh HD/* /Users/myname/

I’d be more concerned about why its looking in the ‘wrong’ place, as its probably actually where it is supposed to be looking and something else isn’t right.

Thanks again Marc. I am sure you are right and the install command is looking in the right place.
The file structure (at least in my Mac which was wiped yesterday and the operating system re-installed, so should I think be considered pretty much a virgin) is:
Macintosh HD

  • Applications
  • Library
  • System
  • Users
    The library (which it seems cannot be moved is therefore directly under the Macintosh HD drive
    When I run the script macOS install command, it looks for:
    Macintosh HD: Users: Myname: Library:, which does not exist, and I don’t seem to be able to create.
    Is there an amendment / preface command the I can enter to make the macOS install command look at a different directory? I am not sure that copying files on its own will help
    Really appreciate the time you have already spent on this

Can you please open a terminal and type these three 4 commands, and show me what the terminal spits back at you?

python3 -m venv homeassistant
source homeassistant/bin/activate
pip3 install homeassistant

I’ve just realised that the last command isn’t in the instructions, but I suspect you need to run it once first before you create the service, and maybe running that creates a ‘library’ directory.

Just guesswork at the moment, like I said I don’t speak Mac so I’m just trying to remotely experiment :slightly_smiling_face:

As a guess it was inspired. I’m in.
Thank you so much for all of your help. Putting up with IT idiots must be frustrating, so I really appreciate that you have helped this idiot through the process.

1 Like