Can't add SmartThings integration

I’m having problems getting past the ‘add integration’ popup when trying to add SmartThings integration. I’ve got a vanilla install of HA and so far it’s added my Hue lights, so the next stage was to work through the instructions to add ST.
I created and activated a nabu casa cloud account which seems to be integrated and working; I can log on to my HA via the NC cloud, and had created the Personal Access Token in my ST account. now here’s the issue:

I’m here in the instructions -

  1. From Home Assistant, navigate to ‘Configuration’ then ‘Integrations’. Click the plus icon and type/select ‘SmartThings’.
    I click on the ‘+’ and a popup appears allowing me to search for or scroll down to ‘smartThings’. I do that and click on it, and nothing - I’m back to the top of the popup and can’t get any further than that.

I’m at a loss now and can’t seem to progress past this which is frustrating, as I have had it working previously on a different Pi running HA, with a different ST account and ST hub. This is all new hardware and location, and new accounts for everything.

1 Like

Replying just in case you still got stuck here, I ran into the same issue. I was able to fix it by going into the following folder

/usr/share/hassio/homeassistant/.storage

I then deleted the smartthings file

Once that was done I restarted home assistant and it allowed me to configure smartthings. Hopefully this will get you sorted.

Thanks Ryan, is there a way to access that using the configurator/File Editor add-on in HA, or do I need to plug in a monitor and keyboard and do it from the command prompt? Not that familiar with Linux, my background is windows/MacOS!

In the supervisor you could try the File Editor addon, after it is installed, from the main supervisor dashboard select it. Next click on the configuration tab at the top, delete the following line from the config

- .storage

Then restart the addon if it is running, or start it. Once it’s started click on open web ui. On the top left click on the folder icon. It should list your files and folders for your home assistant config. Towards the top of the list the .storage folder should appear. Click on it, scroll to the bottom and smartthings should be there. To the left of the file name, click on the three dots and choose delete. Say yes to delete. You can now exit the file editor, and you can add the
- .storage
line back. Afterwards restart home assistant and start the configuration for smartthings again under configuration > integrations.

6 Likes


This is basically as far as I can get. That’s my configuration.yaml file and no - .storage option, hence my frustration. I can wipe the install and try again and see if that helps, although I got a different error last time I tried! :laughing:

Thanks to all - props to rlobbins. I had written a reply that I had deleted the contents of my storage.smartthings file and that I was about to give up. Until I reread this post and discovered how to really delete the file. I am not using Nabu Casa so I also learned that I had to go into Configuation - General - and add my external (DuckDNS) and internal urls so the SmartThings integration could get a webhook. ST is up and running. Next up - Home Panel