Can't connect after PiHole setup

Hi all, I recently set up a PiHole at my home for the whole network, and afterwards I’ve been unable to connect to my HA. I’ve got my home assistant core setup on a RaspberryPi 4 that’s been running without issue for more than year now. I’ve got cloudflare tunnel setup (thanks to this video https://www.youtube.com/watch?v=xXAwT9N-7Hw) and access it via that. I noticed that once I set up my PiHole, the tunnel I use to connect now shows as “inactive” and I can’t connect to HA at all. I’ve not changed any other settings on HA or Cloudflare.

What I’ve tried:
I’ve tried undoing the PiHole changes (switching the auto assigned DNS by ISP to ‘yes’ from ‘no’) to no avail.

Creating a new tunnel for the same DNS results in the same ‘inactive’ status.

My question is 2 fold:

  1. Does anyone know how I messed up my HA instance and how to undo it?
  2. Does anyone know a way to locally access my HA instance to maybe fix the issue so it can run with PiHole? I’m unable to access it via the URL for the cloudflare tunnel, and I can’t access it via the HA IP or the http for homeassistant.local. Is there another option?

Thanks in advance!

  1. Undo what you did to confirm that your instance is in fact, working, and then go from there.
  2. locally you should be able to access it via IP or hostname, unless its not running.

What do your logs say?

Thanks for the reply.

I did try and undo everything and that’s when the cloud flare tunnel wouldn’t change back from “inactive”. I’m also not able to access the HA setup locally like I said, even though the IP. I was able to plug the pi into a monitor and confirmed the instance is running, but since I can’t connect outside of plugging in a monitor I can’t check the logs.

The only hint I have to why it stopped is the tunnel going inactive from active and not switching back.

If you can plug the pi into a monitor you can check the logs, unless you’ve got some weird convoluted type of setup.

Also, why are you tunneling traffic locally? I don’t mess with cloudflare, but I would think you’d only need to tunnel from outside to your router/server. Everything after that should be the same.

If you can access it from outside I’d recommend maybe just doing a backup, nuking the running service from orbit, and reinstall.

Its hard to troubleshoot when there’s so many ‘methods’ for running something as simple as home assistant these days.

1 Like