Can't connect Google Home to Hassio

After moving to a new ISP i’ve done a clean install of hassio+DuckDNS addon on a Rpi3. I ran into some issues with CG-NAT, but that’s now solved and everyting works fine except the ISP blocks 80 and 443 inbound, so I’ve had to stick with 8123.
Everything works fine and I can connect externally and internally apart from Google Home. I’ve had it working fine in the past, and I’ve followed all of the instructions to the letter, adding port number 8123 to URLs in all of the right places. However, when I try to link my [test] project to HA, I get the “Couldn’t update the setting. Check your connection” message and the linking fails.
The only thing I can think of is that it somehow doesn’t work with port blocking, Has anyone had any kind of success with this setup?

Hi, this is how I overcame the CG-NAT limitations and configured HA to work with Google Home: Expose Home Assistant on CG-NAT networks –