Can't connect to Home Assistant via HMY after moving (Tried (local IP, homeassistant.local…)

Hello, I recently moved into my new apartment a few days ago. Everything works fine except when I try to connect to my home assistant. It was working last week. I use Unifi for my firewall and VLAN setup but didn’t set up anything different

I’ve rebooted the router and HA, and I can now ping HA. (I wasn’t able to ping it before.)

I closed my browser and tried to reopen it. It says the site can’t be reached and that “homeassistant.local refused to connect”.

I switched to a different browser, the same thing. I’m unable to connect through Nabu Casa. It just says, “Connection failed: No response from instance.”

Then I figured I’d just do a factory reset and restore from my backup earlier today.

I did the factory reset (unplug the power, plug back in, push the red reset button with a paper clip until the yellow led flashes and wait). It’s still not available so I can’t install from back up.

I can see it on my router interface, and it still has the correct IP address.

if anyone has any suggestions or ideas, I’m all ears!

Check http section of homeassistants config file

I tried that but no luck unfortunately.