Can't detect Yeelight in HASS

Tags: #<Tag:0x00007f3269630ec8>

I’m a bit stuck getting Yeelight 1S (Color) added to HASS.

I’m following the Example configuration (Automatic) but the lights aren’t detected in home assistant and I’m not sure what to replace light.yeelight_color1_XXXXXXXXXXXX: with in the config.

The bulbs are model YLDP13YL.
They are on firmware 2.0.24 with no fw update available in the Yeelight app.
The bulbs have LAN control enabled.
I’m running HASS 0.114.4 as a virtual appliance.
HASS has been able to detect a couple of other devices eg. my router and printer, which appeared automatically in Integrations.

The example config is for automatic discovery. If HA isn’t discovering, then you can manually set them based on IP from your router. You will need to give them a static/reserved IP in your router first.

Example from my config.


      name: Steps
      name: Hall
      name: Table
      name: Toilet
      name: Front Gate
      name: Downstairs
      name: B1
      name: B2

Also, please adjust your category, Yeelight is not a 3rd party integration.

I think I read in the beta notes for 0.115.0 that Yeelight will become configurable via the integrations tab, so there may be a breaking change, make sure to read the release notes of 0.115.0 before you update in case something changes.

I have the same issue. I tried adding the bulbs using the Integrations UI, but it fails to find the bulb even when I put in the IP address.
My bulbs are in a separate VLAN, so I’m not sure if that’s why it can’t find them.
Either way it was working fine in v0.114

I’m able to automatically add the yeelights via the UI with 0.115.0, but only as entities. I’m not able to do a lot with the yeelights when added as only an entity. Do you know if there’s a UI method of adding them to a device, or as devices in version 115? If this isn’t possible would your configuration example work with automatically added devices?

Thanks for the feedback about the category. If you’d like to suggest a more appropriate category for this post I’d appreciate it.


I’m not sure what you mean by this ? Are you saying you can’t use the lights?

I’m not sure what you mean by this ? Are you saying you can’t use the lights?

Yes. The bulbs aren’t in overview, devices, or available to add to a scene. I can’t find any control for the devices in hass after adding via gui.

So you have no entries like this in Developer Tools ---> States, for the lights?

Configuration & tagged with Yeelight would be a better place.

That’s correct: no entries exist for the lights in developer tools --> States.

And the lights are connected correctly to your router and you can control them with the Yeelight app on your phone?

Yes. I can control them with Yeelight & Homekit apps as well as via telnet.

and you have config that looks like this in configuration.yaml?

      name: Living Room

No, I used discovery via the UI to add the bulbs.

OK, so try and add in one bulb with the config listed above using the IP from your router, reboot HA, and see if you can see it listed.

After following the instructions I do not have any entries in Developer Tools --> States, or Configuration --> Devices for the bulb.

I can see the friendly name for the one bulb which was added to the configuration the Yeelight panel in Configuration --> Integrations, additional to the two entries which were added via discovery in the UI.

What do you see when you click on that device? Does it show a new window that has “1 device” and 1"entity"?

No, it’s just Yeelight, Friendly Name. Below that there is Rename and Options and a menu icon that contains System Options and Delete.

I have this for Yeelight in configuration.yaml and have all devices manually listed by IP according to the config I listed earlier.

    - yeelight

Are the bulbs on the same LAN as HA? Have you doubled checked you have LAN control enabled in the app?

I can turn the bulb off & on via telnet control, the LAN Control switch is enabled in the Yeelight app.
HA & the bulbs are all on the /24 subnet

telnet 55443
Connected to
Escape character is '^]'.

Have you tried this in configuration.yaml?

    - yeelight

      name: NAME OF BULB