Can't detect Yeelight in HASS

Tags: #<Tag:0x00007f326cd1d260>

This is the whole configuration.yaml , most of it’s default content.

# Configure a default setup of Home Assistant (frontend, api, etc)

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

    - yeelight

      name: Desk Lamp

Have you had a look at : ?
Apparently, there is a bug when HA and yeelight are not in the same subnet. Looks like it is your case.
Revert back to 0.114.3 “fixed” the issue for me. It should be corrected in an upcoming 0.115.x

1 Like

I’ll take a look, to clarify though the Yeelights and HA are both on the same /24

Have you got a “special” network configuration? E.g some firewalling rules out or in HA ?

Nothing special, it’s all consumer grade stuff. No firewall running on the LAN traffic.
HA is connected to Wireless AP / switch, Yeelights are running off a different AP that’s connected to the other AP via ethernet.

This one fixed my issue, got the same scenario described by Skirmish.

How did you fix your issue?

I found I’m able to temporarily pick up the lights if I do the following:

  1. Power bulbs off
  2. Power bulbs on
  3. Reboot HA’s host

Unfortunately it’s only a temporary fix: they drop out again after a while and the entities’ status is listed as “Restored” with a red circle.

I’ve tried variations on the above procedure but all three steps are definitely required for the entities to come up properly in HA.

from that PR, I grabbed the yeelight component and put it under custom_components and then restart. It was able to scan my yeelights under integrations. Make sure to remove it once there’s a new HA release containing that PR.

Hi. New here but not shy about it. Can you give me a little more detail as to what you copied, where you got it, and where you put it please? Thanks!

  1. Download the zip or git clone this
  2. Copy the yeelight folder from that zip/git (homeassistant/components/) and paste it to custom_components on your config folder.
  3. restart
1 Like

I have upgraded to 0.115.3 hoping the fix to be included but apparently not…
As explained in Yeelight in 0.115 not working yeelight is working fine in 0.114.4 and can’t be managed in 0.115.x (tried .1 and .3).

This is the result of a known issue. The bug for the issue is this one: After HA upgrade to 0.115.0b8, yeelights entities are not available. (There’s another issue for the same problem, not yet marked as a duplicate.)

There is a "pull request"1, Fix yeelight connection issue, currently in progress. But it’s not yet "merged"2, so the problem isn’t fixed as of HA version 0.115.6. It seems like it’s going to take some additional work for the PR to be ready to be added to a HA release.

1 A pull request, or “PR”, is GitHub mechanism for proposing an improvement to a piece of code. In this case, think of it as a candidate fix that’s not yet verified or approved.

2 Merged is git terminology for “accepted” or “incorporated”. In this case, because the pull request isn’t merged, we’re still waiting for the fix to become available.

so I’ve just updated to 0.116.1 but the issue seems to be still present.
Any idea about the release date? I’ve 5 Yeelight Bulbs and I can’t use them in HomeAssistant :frowning:

Thansk in advance