Can't extract Philips Xiaomi key with MiToolkit

Tags: #<Tag:0x00007f3f1a03d8f0>

Hi!

I’m trying to extract a key to control my Philips Xiaomi from Home Assistant.

When following this guide: https://home-assistant.io/components/vacuum.xiaomi_miio/#retrieving-the-access-token I get stuck at step 7. The backup is created successfully, but shortly after the MiToolkit gives the following error: 'system cannot find the file specified.
image

I’ve tried two different smartphones and computers. Is anyone else experiencing this problem?

Thanks!

Run the tool as Admin, Right click the file and choose "Run as Administrator"
This solved the error massage for me.

1 Like

Huh, I’ve never seen this before. Have you solved the problem? Is the backup being created on the phone? Do you see any progress being made on that side of things?

It does show the backup being created on my phone, the steps look normal until the error is given.
Unfortunately running the program as administrator also doesn’t help.

1 Like

this solve it for me. thanks alot!

update: using the mihome app v 5.5.30 doesnt store any token in database anymore.
one way to get the token is to downgrade the mihome app.

1 Like

thanks finally got the token also after installing java and downgrading Mi Home to 5.1 from https://www.apkmirror.com/uploads/?q=mihome