Can't ignore auto-discovered integrations

I’ve got a Vizio speaker that keeps getting found by autodiscovery. At this point it’s showing up 3 times in my integrations page. There is no option to ignore the discovery though! I had that option on 1 card one time and I selected it, but that just got rid of the one card and left 2 others. The speaker showed up again just yesterday as an auto-discovery!

How do I get this thing to stop showing up? I tried adding adding this to my configuration.yaml:

discovery:
  ignore:
    - vizio

But that’s not a valid option for the ignore list for discovery according to the configuration validator, nor is it listed in the documentation for the discovery service.

I had added this integration once, but it wasn’t useful to me and the speaker still kept getting discovered when it was turned on (same IP and port) even after I had done that! I just want it to go away and stop bothering me!

I’m having a similar issue with a vizio smart tv.

After updating to v115 my vizio tv keeps getting discovered…even tho I’ve already configured it. I keep dismissing it but about half the time I restart it shows back up.

Not really a big deal but it does get a bit annoying.

0.116.1 and still no way to ignore this integration.

I see some fix was implemented in the config flow that was supposed to stop this from happening but I still get the same discovery as everybody else does. @raman325 any news on this, I think you made the changes. Apologies if I have that wrong.

No you are correct as this has been reported in Discord as well - I am still investigating the issue, I will push a fix once I have it

To anyone who is facing these issues, when you click on configure, did you see any errors on the form? Just trying to figure out where the branching logic is not doing what I expect.

Here’s what I see:

When I hit submit, I get:

thanks @sgruby when does the Aborted notification occur? When you try to submit?

Please continue this discussion in https://github.com/home-assistant/core/issues/31642, it will be easier for me to track comments/feedback in one thread

Aborted comes after I submit. I’ve moved my reply to GitHub for you to track. Thanks!