Can't install Hassio Update 0.96.1 / 0.96.2

Hi there,

i tried to install 0.96.1 , i’m on 0.95.4. It didn’t work.
Than i got the message, that 0.96.2 ist available.
I also tried to install on the Webinterface with the “update button”.

It didn’t work. The error is called @ System log:

19-07-20 19:07:23 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.96.2
19-07-20 19:07:23 INFO (SyncWorker_6) [hassio.docker.interface] Update image homeassistant/raspberrypi3-homeassistant:0.95.4 to homeassistant/raspberrypi3-homeassistant:0.96.2
19-07-20 19:07:23 INFO (SyncWorker_6) [hassio.docker.interface] Pull image homeassistant/raspberrypi3-homeassistant tag 0.96.2.
19-07-20 19:07:25 ERROR (SyncWorker_6) [hassio.docker.interface] Can’t install homeassistant/raspberrypi3-homeassistant:0.96.2 -> 500 Server Error: Internal Server Error (“readlink /mnt/data/docker/overlay2/l: invalid argument”).
19-07-20 19:07:25 WARNING (MainThread) [hassio.homeassistant] Update Home Assistant image fails

is this error on my Raspberry Pi ?
What can I do?

Thank you for the help

The update server may be down. Wait and try again later.

I also received this error when trying to update. It seems I had corrupted something.

I ended up taking a snapshot and copying it to my PC with WinSCP, and then flashing a new image on the SD card before copying the snapshot back and restoring.

Not knowing your setup, I don’t know if this is the same issue, but it fixed mine.