Can't reach Web Interface after installation

Hello there,

Yesterday I followed this link :

After installation successfully completed I succeeded entering the web interface but after a restart I can’t reach this site anymore :
http://raspberrypi_IP:8123
no matter what I try.

double checked my raspberry pi address to make sure I’m trying to access the right address.

Does someone have a clue how to fix it ?

thanks

Did you set Hassio autostart? What happens if you start it manually? Any error in the log file?

1 Like

I set it to autostart after boot but nothing happened, still ‘can’t reach site’ message
I typed manually in the terminal : /srv/homeassistant/bin/hass -c “/home/homeassistant/.homeassistant”
and got a very big log which at the end I’m getting a warning : homeassistant.setup:Setup of recorder is taking over 10 seconds.

where can I find the log file ?

In addition, when I type : “sudo systemctl status home” and then press tab it does not autocomplete home-assistant for example or after : “sudo systemctl status home-assistant.service” it answers : " Unit home-assistant.service could not be found"

anyone ?? please help me

Did you try localhost:8123 ? I think that’s what I had to use on mine when I first set it up.

Also we really need to see the log to be of much help if that doesn’t work

… also are you sure your autostart is working? Did you try manually starting Hass?

Autostart seems to be broken/not set up.
The guide you are refering to does not include autostart.
Have a look at this https://home-assistant.io/docs/autostart/systemd/

Or you can flash your SD with HASSbian witch will give you the same result as what you are trying here.
https://home-assistant.io/docs/installation/hassbian/installation/

“Did you try localhost:8123 ? I think that’s what I had to use on mine when I first set it up”

Do You mean to type localhost:8123 in the raspberry pi web ?

“Also we really need to see the log to be of much help if that doesn’t work”

Where is the log located ? please guide me to its location

“… also are you sure your autostart is working? Did you try manually starting Hass?”

As I stated above, I typed in the terminal the command line : /srv/homeassistant/bin/hass -c "/home/homeassistant/.homeassistant and it says its start but when I try to open the http://IP_ADRRESS:8123 , I get the message : "site can’t be reached"

I followed this guide exactly but it’s even doesn’t start manually by entering the virtual environment …

I’m newbie to linux systems and I bought the raspberry pi not especially for the Home Assistant but also to learn how to work with linux OS. Will HASSbian will give the opportunity to or as hass.io it will block me from doing things not related to Home Assistant ?

Hassbian, is a normal Raspbian install with home assistant already installed and configured for automatic start. Raspbian is just Debian Linux for the pi. You will have full access to the OS and get a much better understanding of Linux vs Hassio

HASSbian is basicly the same as what you tried here, it is not the same as hassio and does not limit you the same way.

OK, I flashed my sd card again with hassbian using etcher and installed it on my RPI. I succeeded (hope not just for now) to access home assistant from another computer on the same network via IP_ADRRESS:8123 but couldn’t via http://hassbian.local:8123 (why is that ??)

another question : why now can’t I see any linux gui as I saw the first time I’ve installed RASPBIAN STRETCH WITH DESKTOP so I can see what folders do I have in the RPI and in what locations ? what I see is just a black screen with a pi@hassbian and prompt >

This is has to do with DNS, not evry network is the same, but IP should always work.

This is because HASSbian is based in Raspbian Lite, the one without GUI, this is normal for an “headless” installation.

What do you mean by “headless installation” ? and now, how will I know what folders do I have in the computer ? It’s like someone dropped you in a maze and you need to scout

It refers to an system that is designed to be used without KVM(Keboard, mice, monitor).
You control your server with SSH.

If you want to “see” your files, look at commands for Debian/Raspbian.
Or for your home assistant configuration you can expose them with Samba

$ sudo hassbian-config install samba

Hmmm… I understand.

But can I install other things on the RPI except the Home Assistant ?
Can I treat/ appeal the system as a regular linux (without the desktop UI of course) or with the hessbian I’ll be limited to the Home Assistant and the main role of the RPI will be - controlling the HA via SSH.

What are the advantages of the hassbien installation over the hassio installation ? I am asking that because I see no deference between them from the point of the RPI use except the HA.

Yes. Install away…

You can even add a desktop if you really want it. Hassbian is just raspbian with home assistant pre configured to run on startup. That’s it.

see above. You can do whatever you like with Hassbian. With HASSIO you are limited to what addons are offered.

@flamingm0e I think the real answer that @kobip needs is: How do I install the desktop environment on Hassbian?

This is the guide for one desktop environment (Pixel):
http://thecodermag.com/installing-gui-raspbian-jessie-lite-destros.html

1 Like

Thanks! I’ll check this out