Cant see input_booleans

Im new to HA, but have some automations running and have generally found my way around OK. Im using HA core installed on Ubuntu.

Im trying to add an input_boolean which I want initialised, so via yaml.

I tried it in the config.yaml file, and using an include. After a config check and a restart a check of the logs - everything looks OK.

But I cant see the input boolean anywhere. I try adding an entity condition, but it doesn’t appear there. Nothing in developer tools, states either.

Im missing something really simple. I assume Im supposed to be able to see the input boolean and so add it to conditions etc. But what am I doing wrong?

config.yaml:

# Loads default set of integrations. Do not remove.
default_config:

# Load frontend themes from the themes folder
frontend:
  themes: !include_dir_merge_named themes

automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
input_boolean: !include input_booleans.yaml

# UniFi controller configuration
unifi:
  controllers:
    - host: zoner
      port: 8443
      site: default
      username: user
      password: password
      verify_ssl: false

# Device tracker using UniFi controller
device_tracker:
  - platform: unifi
    consider_home: 180  # Optional: Adjust the consider_home parameter as needed

template:
  sensor:
    - name: Winter_State
      state: "{{ 'winter' if now().month in [6,7,8] else 'not_winter' }}"

input_booleans.yaml

away_enuf_A:
  name: Away sufficent for repeat action
  initial: true

The only minor things I can suggest to try are:

  • make the slug lowercase, so away_enuf_a.
  • add a label to the header in case your input_boolean is clashing with something in default_config, so:
input_boolean manual: !include input_booleans.yaml

Then a full reboot, and watch the logs.

Thanks for the suggestions. I tried the lowercase, then the label with a systemctl restart inbetween. Sadly no change. Logs are clear.

I can add the boolean through the UI, but am unable to initialise it hence my desire for YAML, aside from wanting to do more complex things.

Im baffled. It simply seems to ignore the input_boolean no matter where I put it in YAML. I even removed its initialisation to make it very simple, but no joy.

Clutching at straws, Im editing ~/.homeassistant/input_booleans.yaml (and the config file there) on Ubuntu 20.04 on * Core 2024.6.3 Frontend 20240610.1

Why is it not being picked up, nor displaying any warnings or errors? Hmmmm

You say “config.yaml” above: are you sure you’ve edited /config/configuration.yaml to add the include line for the input_booleans?

Might seem obvious but we’ve had cases before where the real configuration.yaml wasn’t the one being played with…

Well that would certainly fit the symptoms. I installed home assistant using these instructions. I confess to having little knowledge about python virtual environments at the moment (too much to learn with HA!). I assumed it uses the config files in /home/homeassistant/.homeassistant, but maybe not?

As a side note, the boolean_inputs.yaml source statement is in the pasted configuration.yaml file in the previous post. Looks right.

Update: located the venv setup using sudo systemctl cat [email protected], which in turn pointed to the location of the yaml files it is actually reading :laughing:

1 Like