Can't seem to change anything in the configuration file

Hello everyone. I’m extremely new to all of this so hopefully you can help me out and excuse my total ignorance.

I am trying to follow along and get some lights working as seen in this video. https://youtu.be/9KI36GTgwuQ

Some things have changed apparently from when this video has been made, so I’ve had a hard time getting things going.

So far I have the ESP8266 module working and connecting, I have HA loaded on my pi 3 with MQTT, SSH and Samba turned on. My ESP8266 is connecting to the MQTT successfully.

My problem lies whenever I try to paste any of the config examples he links to into my configuration file. It will either fail when verifying, or Home assistant will give an error when starting up saying it didn’t add it and check configuration.

Even when I copy and paste a sample MQTT json light right from the Home assistant website into my config it says it wasn’t able to add it on the overview page.

What am I doing wrong?

Ok, so I seem to be getting some of this stuff to work ok in the configuration file now. But when I try to paste the code for an input slider ir gives me an error "Failed config
General Errors:
- Component not found: input_slider
- Setup failed for input_slider: Component not found.

Successful config (partial)"

Here is my config. let me know what I’m doing wrong please Thanks

homeassistant:
  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: 44.5668
  longitude: -69.8822
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 74
  # metric for Metric, imperial for Imperial
  unit_system: imperial
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: America/New_York
  # Customization file
  customize: !include customize.yaml

# Show links to resources in log and frontend
introduction:

# Enables the frontend
frontend:

# Enables configuration UI
config:

http:
  # Secrets are defined in the file secrets.yaml
  # api_password: !secret http_password
  # Uncomment this if you are using SSL/TLS, running in Docker container, etc.
  # base_url: example.duckdns.org:8123

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
updater:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically
discovery:

# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Enables support for tracking state changes over time
history:



# View all events in a logbook
logbook:

# Enables a map showing the location of tracked devices
map:

# Track the sun
sun:
    
# Weather prediction
sensor:
  - platform: yr
# Text to speech

tts:
  - platform: google

group: !include groups.yaml
automation:
  - alias: "Porch Animation Speed"
    initial_state: True
    hide_entity: False
    trigger:
      - platform: state
        entity_id: input_slider.porch_animation_speed
    action:
      - service: mqtt.publish
        data_template:
          topic: "bruh/porch/set"
          payload: '{"transition":{{ trigger.to_state.state | int }}}'          
script: !include scripts.yaml

light:
  - platform: mqtt_json
    name: "Porch Strip"
    state_topic: "bruh/porch"
    command_topic: "bruh/porch/set"
    effect: true
    effect_list:
      - bpm
      - candy cane  
      - confetti  
      - cyclon rainbow  
      - dots  
      - fire  
      - glitter  
      - juggle  
      - lightning
      - noise  
      - police all  
      - police one  
      - rainbow  
      - rainbow with glitter  
      - ripple  
      - sinelon  
      - solid  
      - twinkle  
    brightness: true
    flash: true
    rgb: true
    optimistic: false
    qos: 0

input_slider:
  porch_animation_speed:
    name: Porch Animation Speed
    initial: 150
    min: 1
    max: 150
    step: 10

change input_slider to input_number

it was changed a few releases ago.

Thank you. Do I need to change it everywhere “input_slider” is referenced? Or just in the first input_slider: line?

Input number is now working. Now I’m getting this. There must be something wrong with the light component?

yes. change it everywhere if necessary.

i have no experience with the bruh light, but from your configuration.yaml it looks like you don’t have an mqtt broker set up since there’s no mqtt: line. see here: MQTT - Home Assistant

I installed the MQTT Mosquitto broker from the hass.io add-ons list and started it. My ESP8266 Does connect to it as well if I use the serial monitor in the arduino IDE

I can see this in the log from the mosquitto broker

“1512434104: New connection from 192.168.0.15 on port 1883.
1512434104: New client connected from 192.168.0.15 as porch (c1, k15).
1512435899: Saving in-memory database to /data/mosquitto.db.
1512437700: Saving in-memory database to /data/mosquitto.db.”

As you can see the “porch” is my ESP8266

Do I need to do it differently to make this work?

have you added the mqtt: line to configuration.yaml? just as a line by itself. otherwise i don’t think home assistant knows about the broker.

Yup, I just did that and it is all working! Thank you everyone for the help. It’s all up and running!