Can't update HAOS 6.6 to 7.0

Hi All,

I tried to update HAOS 6.6 to 7.0
Its say: backup operation system… but then I see a error message (so fast you can’t even read it)
then it stop and there is nothing updated.

Also no error messages in log files…

HA 6.6 on a RPi4 on SSD
HA behind a cloud flare config.
28GB used space and still 78GB free space on SSD

There is a backup file of OS 238MB in size…

I did a Check Home Assistant configuration (add-on) and thats goes without errors.
So downloading new updates is working.

EDIT: The update of HA Supervisor is updated without errors to 2021.12.1


Same here. I’m running HA 6.6 on a RPi3 with SD card, 78% free space.
Partial backup created is 298,2 MB, then the update stops without an error in the log files.

Everything else works, also the updates to core-2021.12.0 and supervisor-2021.12.1 were no problem.
A complete backup created independently is 327.9 MB.

How much actual free space? With a small SD Card space could still be am issue.

I’m not able to update from 6.6 to 7.0 either. I’ve tried it twice, and each time a backup of 6.6 is created, but no update is done. This is with an RPi4 and a 256GB SSD (less than 10% used).

System Health

version core-2021.12.0
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.7
os_name Linux
os_version 5.10.17-v8
arch aarch64
timezone Europe/Amsterdam
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 4920
Installed Version 1.18.0
Stage running
Available Repositories 972
Installed Repositories 11
Home Assistant Cloud
logged_in true
subscription_expiration 19 December 2021, 01:00
relayer_connected true
remote_enabled false
remote_connected false
alexa_enabled true
google_enabled true
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 6.6
update_channel stable
supervisor_version supervisor-2021.12.1
docker_version 20.10.8
disk_total 228.5 GB
disk_used 22.3 GB
healthy true
supported true
board rpi4-64
supervisor_api ok
version_api ok
installed_addons Samba share (9.5.1), File editor (5.3.3), InfluxDB (4.3.0), Terminal & SSH (9.2.1), Grafana (7.3.2), Z-Wave JS to MQTT (0.31.1), TimescaleDB (1.1.6), DSMR Reader (0.7.0)
dashboards 2
resources 8
views 4
mode storage

It is a 64GB SD card. df -h says: 43.4G free. There must be something else.

Same for me. RPi 4 with SSD and more than 200GB free space. Backup is successfully created.

Same problem here, raspberry pi 3 b with 128G of SSD and just 12% used. Make the partial backup and after a while a error message appear but is fast and I can’t read.

raspi 4 8gb ram 64gb micro sd 30gb used
it mags a backup but nothing else not even a error message

Same here. RPi 2B with 47Gb free on a 64Gb micro sd.

Strange, mine will not perform either update. Same basic symptoms. It performs the backup but then nothing happens. No errors in the logs just nothing. I am getting the same result when updating the core myself.

I am running a HA Blue.

I take that back after hours of trying it did finally update the Core to 2021.12.1 but the OS is a no go

Same problem on Blue

+1 with a blue.

21-12-13 16:07:35 INFO (MainThread) [] 'BackupManager.do_backup_partial' blocked from execution, system is not running - CoreState.FREEZE

Seeing all these issues here and on github, maybe the update should be retracted until a fix is available? Glad I ran into this befiore I noticed there was an update.

Same problem here, running as a virtual machine using Proxmox. Update the Core to 2021.12.1 is working but the OS is a no go

same here, already tried some time before the core upgrade, since the HA OS upgrade is available for a bit longer. But no luck, not before, not now. I keep removing the HA OS 6.6 backups, as they are -for now- useless.
Some extra details, in case people want to find similarities:

Host Operating System Home Assistant OS 6.6
Update Channel beta
Supervisor Version supervisor-2021.12.1
Docker Version 20.10.8
Disk Total 458.4 GB
Disk Used 25.1 GB
Healthy true
Supported true
Board rpi4-64
Supervisor API ok
Version API ok
Installed Add-ons Home Assistant Google Drive Backup (0.105.2), File editor (5.3.3), Glances (0.14.0), ESPHome (2021.12.0), NGINX Home Assistant SSL proxy (3.0.2), Let’s Encrypt (4.12.0), Samba share (9.5.1), Mosquitto broker (6.0.1), ZeroTier One (0.12.1), InfluxDB (4.3.0), Node-RED (9.2.0), Zigbee2mqtt (1.22.1-1), TasmoAdmin (0.16.0), Visual Studio Code (3.6.2), AppDaemon 4 (0.6.2), SSH & Web Terminal (9.1.1), SQLite Web (3.2.0)
1 Like

After 6 times I saw the message: LOST CONNECTION…

Then it was hoping the OS will reboot normal and start normal without freezes, or errors…

After a long boot proces everything was running again and normal…

So it will take some times to update the OS, but here after 6 tries im done.

I think I already tried 10 times over the last 7 days. Still no luck. Something must be fishy. Or at least a better logging should be in place

1 Like

I was very scared to keep trying. If something went wrong and system reboot with some break parts I was needed to build a new one (lucky always have backups of the config)

in fact, for my Raspi 4 config, there’s nothing in this update that would require/tempt me update (no new kernel, only update to UART & ethernet) but I rather not fall behind too much.