Can't use port 443 in the app

I have the HA app set up to work on the IP address when on the home network. That all works fine.
I have also configured my no-ip domain as the external location. This all works fine in a browser but if I set it as the HA location in the app it appears to save, then when I click back in to the settings the port number has disappeared.
Is there no way to use a different port number for the main HA URL?
I’m trying to use

https by default is port 443. Most browsers will remove port 443 from the URL since it’s default. same as if you did, the default port 80 would be removed. But it is still using port 443.

Ah, good point. I replaced it with and it works fine.
Thanks for the pointer.

Just use

I tried that, but it doesn’t work. What I used above works fine.