Can't use replaced ESPHome device

I’m trying to replace a failed RGB lightbulb running ESPHome with a new bulb.
I successfully installed a the old ESPHome configuration on a new bulb.

From the ESPHome dashboard, the new bulb appears correct, with the proper entity ID. I can visit the device or display the logs.

But from the device info for the entity, if I click on ‘visit’, it takes me the the IP address of the old, dead bulb.

How can I fix this, other than renaming the device. I’m tired of the system renaming endities all the time and don’t want to do it myself.

Is there a DHCP table in Home Assistant that needs to be updated? The router’s DHCP is correct.

I can’t seem to delete the old entity in HA, only disable it.


The normal way to replace an old esphome device:
1 - delete the esphome device from the integration list under settings / devices and services (do NOT delete it from the esphome addon!!)
2 - restart HA
3 - build and flash the new esphome device

it would not surprise me if you can skip step 3 as you obviously did that already :thinking:

I tried this.
I restarted HA and espHome.
I gave it a day or two but the device has not returned yet.

The device is there on the espHome integration page. I can look at its logs and visit the device.
But it is not listed on the espHome device list from the settings->devices&services-> integrations page and it is not on the settings->devices&services->devices page.

Have you tried re-flashing it ??

I did re-flash it. Then there was an update on espHome, so it was flashed again.
Then I re-flashed again last night and still not there.

I’m thinking I have to rename it to get it back.

First of all, be sure you removed the old one from the ESPHome integration page:
Settings->Devices & Services->Integrations->ESPHome->device-name->3 dots menu->delete

If the new device is not auto detected, you can add it manually on the Integrations page via the blue button “Add Integration” select ESPHome and add the device via it’s IP address of via “device-name.local”

Deleting everything, restarting everything, and manual “Add Integration” worked!

Thanks very much for all of your assistance.