Cast on 0.109.6

I “broke” it by sending acast command to a non existant view, so i could confirm the service was hitting the hub, but it still went into ambient mode.

@wilhelmstroker your method works, but its VERY clunky. The Wife Approval Factor for HA is out the window with the hub not workin g.

Yup it’s very clunky and annoying. Not sure what to do though, it looks to be a google issue. If only google allowed us to disable ambient mode…

Absolutely, this is the flow I use for this:

What are the contents of that exec call ?
Im just using a service call for cast, which doesnt seem to be working.

I’m actually using Catt to stream.

You should be able to use a node like this one instead of that exec call.

Oh for enough.
Yeah – thats what im using, except that it doesnt work :frowning:

It doesnt bring it out of ambient mode.

I just realised that node read was out of date, and i only had view_path, not dashboard_path. So I have updated that and will report back

I HIGLY recommend giving Catt (Cast all the things) a try.

My camera is way more fluent with it ( Using an Iframe pointing to MotionEye) and I can even click on elements to bring up the more info panel.

Catt seems a far more likely candidate.

Ive managed to get it to work – sort of. The Google Hub displays a login window though.

ah cool, thanks for that! this might just be the reason for me to finally implement node red :smiley:

Yeah, you need to use the trusted networks to log in.

So i got catt to work – outside of HA though, using a cron every 10 minutes.
Its not quite the same, but it is better than nothing.

@Maxi1134 did you manage to work out a way to use catt but still hide the menu / nav bar etc?

Yes! I use Custom Header to hide the Side and Top bar on my hub!

I am also seeing something similar. The Google Home Hub just goes back to the screensaver after a certain amount of time, even though the cast tabs still says it’s casting.

It seems that calling the cast service from HA doesn’t wake it up… Atleast it didn’t in my case.

As per Maxi, I changed mine to use catt, and have a cronjob running outside of HA every 20 minutes to reset it.

I did actually get a response from Google support re some instructions to disable ambient mode, but I haven’t tried it yet.

From Google support :

You can follow these steps to turn off the Ambient mode on your Google Nest Hub:

  1. Swipe up from bottom of the display
  2. Find the light icon in the lower left hand corner
  3. Check that there is an “A” in the light icon
  4. If there is, tap the light icon to turn Ambient EQ off

I tried those steps from Google support. They didn’t make a difference for me.

Same. It appears to just affect the brightness

Anyone knows if the Amazon “Hubs” have this issue?

You can’t cast to any of the amazon devices as far as I know.

Anyone has a good device to recommend that would fill this function without timeout?