Chromecast integration not working in Unraid

The problem

One day last year chromecast’s stopped being available. They were manually entered with cast: in config yaml and the IP addresses. I didn’t use them much through HA so I just removed them. Now I’m trying to get it working again through integrations and it’s no good it says it cant find them. When I enter them into the yaml it shows up in integration with no entities or devices. I’ve enabled mdns, every other thing on my network can see them, they aren’t on vlan or a different subnet or anything special. I only have two networks, guest and everything else. Chromecast are with everything else.

  • Everything on my network can connect to all my chromecast’s except HA
  • Don’t have spotcast like this issue
  • Don’t have pychromecast
  • All Chromecasts are on the same internet connection, no special vlan, subnet etc…

Environment

  • Home Assistant: 0.118.5
  • Last working Home Assistant release (if known): Not sure
  • Operating environment: Container in Unraid Docker
  • Integration causing this issue: Google Cast

Traceback/Error logs

Logger: homeassistant.components.media_player
Source: components/cast/media_player.py:130 
Integration: Media player (documentation, issues) 
First occurred: 2:59:15 PM (1 occurrences) 
Last logged: 2:59:15 PM

Error while setting up cast platform for media_player
Traceback (most recent call last):
  File “/usr/src/homeassistant/homeassistant/helpers/entity_platform.py”, line 199, in _async_setup_platform
    await asyncio.shield(task)
  File “/usr/src/homeassistant/homeassistant/components/cast/media_player.py”, line 129, in async_setup_entry
    [
  File “/usr/src/homeassistant/homeassistant/components/cast/media_player.py”, line 130, in <listcomp>
    _async_setup_platform(hass, ENTITY_SCHEMA(cfg), async_add_entities)
  File “/usr/local/lib/python3.8/site-packages/voluptuous/validators.py”, line 218, in __call__
    return self._exec((Schema(val) for val in self.validators), v)
  File “/usr/local/lib/python3.8/site-packages/voluptuous/validators.py”, line 340, in _exec
    raise e if self.msg is None else AllInvalid(self.msg, path=path)
  File “/usr/local/lib/python3.8/site-packages/voluptuous/validators.py”, line 336, in _exec
    v = func(v)
  File “/usr/local/lib/python3.8/site-packages/voluptuous/schema_builder.py”, line 272, in __call__
    return self._compiled([], data)
  File “/usr/local/lib/python3.8/site-packages/voluptuous/schema_builder.py”, line 817, in validate_callable
    return schema(data)
  File “/usr/local/lib/python3.8/site-packages/voluptuous/schema_builder.py”, line 272, in __call__
    return self._compiled([], data)
  File “/usr/local/lib/python3.8/site-packages/voluptuous/schema_builder.py”, line 594, in validate_dict
    return base_validate(path, iteritems(data), out)
  File “/usr/local/lib/python3.8/site-packages/voluptuous/schema_builder.py”, line 432, in validate_mapping
    raise er.MultipleInvalid(errors)
voluptuous.error.MultipleInvalid: extra keys not allowed @ data[‘host’]

Please show your config, looks like you have host: in there, which is not a valid option.

Ahhh ok I’ll look into that. Host worked before so I was just uncommenting it when it came time to try again.

#GOOGLE Cast
cast:
  media_player:
    - host: 192.168.1.40
    - host: 192.168.1.41
    - host: 192.168.1.99
    - host: 192.168.1.221

Anyway,if your devices are not discovered, manual config will also not work.

You are correct. Manual config did not work. Got an mdns scanner and that app sees it right away, put the uuid now theres no error just a blank google cast integration with no entities or devices

#GOOGLE Cast
cast:
  media_player:
    - uuid: "746ea805-1bae-6fd4-dbd0-163e33b4c740"
    - uuid: "411599d0-fa58-8161-a4b7-850bf858d34d"

Even if you have the UUID in there, it will not woek when they are not discovered. The manual config is only to exclude devices.
Do you have host network mode for the Home Assistant Container?

Ahhh crap. So I drop it into host mode and bam these two pop up nice and ready.

Problem is I use a custom network type because I have a reverse proxy setup. Is there a general rule to that?

I also have a custom network and use a reverse proxy and HA in network mode.

1 Like

Well you pushed me down the right path and I fixed it! Many thanks!

For anyone else in my shoes I found this post on reddit Unraid fix

Basically You can put it in host mode if in the nginx config file you change the two instances of

proxy_pass http://[local IP]:8123;

instead of

proxy_pass http://$upstream_homeassistant:8123;