Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)

hassio-addon
Tags: #<Tag:0x00007fd0767edfd0>

#242

Hope they fix it, was one of the coolest feature of HASS.

Shall we revert back to TTS?


#243

Which Friday?


#244

I also get this message, any solution?


#245

Please follow the thread I posted as it had the latest updates. They tried to update but had to roll back so the new ETA is next Friday.


#246

With Google, when they say “next”, alwasy ask in which YEAR


#247

Hey all

I’m running this from a docker container on my QNAP NAS. When I connect to :9324 to authenticate, it gives me the following error.

400 Bad Request
Illegal key ‘ys-api/dvr/entry/grid_upcoming’

Traceback (most recent call last):
File “/usr/local/lib/python3.5/dist-packages/cherrypy/_cprequest.py”, line 733, in process_headers
self.cookie.load(value)
File “/usr/lib/python3.5/http/cookies.py”, line 556, in load
self.__parse_string(rawdata)
File “/usr/lib/python3.5/http/cookies.py”, line 620, in __parse_string
self.__set(key, rval, cval)
File “/usr/lib/python3.5/http/cookies.py”, line 512, in __set
M.set(key, real_value, coded_value)
File “/usr/lib/python3.5/http/cookies.py”, line 380, in set
raise CookieError(‘Illegal key %r’ % (key,))
http.cookies.CookieError: Illegal key ‘ys-api/dvr/entry/grid_upcoming’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/local/lib/python3.5/dist-packages/cherrypy/_cprequest.py”, line 631, in respond
self._do_respond(path_info)
File “/usr/local/lib/python3.5/dist-packages/cherrypy/_cprequest.py”, line 659, in _do_respond
self.process_headers()
File “/usr/local/lib/python3.5/dist-packages/cherrypy/_cprequest.py”, line 735, in process_headers
raise cherrypy.HTTPError(400, str(exc))
cherrypy._cperror.HTTPError: (400, “Illegal key ‘ys-api/dvr/entry/grid_upcoming’”)

Any ideas?


#248

Looks like it’s working again!


#249

Interesting… I’m still getting “It looks like I can’t broadcast right now” in my history.
I tried restarting the add-on but no changes.
Are you still using the x.x.x.x/broadcast_message?message=“this is a message” URL ?
Is there any update to the code of the add-on ?


#250

I was too up until 30 seconds ago. Looks like its a gradual roll out maybe. No update to the code needed.


#251

Works for me. But I did a fresh install now, as I was waiting for this to come back again. Is the “Open web UI” option supposed to show anything?


#252

I’m assuming you mean the button in the hass.io addon? If so then it will only do something when you first set it up. It will take you to port 9234 which will make you log in with your google credentials. After its setup it moves over to port 5000.


#253

I can confirm it works for me again now for broadcast. Is there any way to give commands such as “play radio station on the bedroom speaker”? I tried and I can’t get it to work.

Is it possible to just broadcast to a single speaker?


#254

No and No,

You can send specific commands like “turn on x light” and that works but certain things like media are at this point restricted.

Also at this point broadcast is all or none. The only exception is that you can disable notifications from going to a specific google home in the google assistant settings but that is an all or none option.


#255

Thanks for confirming, I already used the light control commands. Not much use as Hass can control them anyway. Was hoping to start playing media in a certain room when you turn on the light in Hass. Anybody any other ideas on how to use this. Announcements for outside motion sensor triggered or fridge door left open are other ideas I have.


#256

Working again for me! Strange


#257

Working again for me. Strange, yesterday night the logs showed it couldn’t broadcast. Maybe this was a staged reactivation from Google, DC by DC.
Anyway, happy I have all my vocal notifications again!


#258

Yippee! Working again!


#259

Anyone know if it is possible to get this to read out values from home assistant such as temperature sensors, etc?


#260

Thanks so much to the team that got this working again on Google’s side. The quality of the voice when broadcasting is way better than the TTS solution.


#261

Also, thanks to everyone supporting the addon. It has officially reached over 10k pulls on Docker Hub. :tada: