Home Assistant Community

Community Hass.io Add-on: Grafana

hassio-repository
hassio-addon
Tags: #<Tag:0x00007fcf4a11c850> #<Tag:0x00007fcf4a11c710>
#61

Hi!

Getting an issue with using Grafana graphs in iframes in lovelace after the last release.
The legend is showing, but getting the following error message.

The iFrame works when pointing to the “link” adress instead of the “embed” adress as I was doing before, But that does not give the result I am looking for.

Thanks for your assistance!

#62

Nice job keeping this up to date. :slight_smile:

Has anyone used this addon with MariaDB 10 / MySQL database?

All of the guides I’ve found so far only document using InfluxDB which looks to be ‘SQL like’ so I guess the settings are pretty similar?

The HA guide is here: https://www.home-assistant.io/blog/2015/12/07/influxdb-and-grafana/

EDIT: The included MySQL datasource seems to be working for me now. :slight_smile:

#63

Same issue in my config after latest update.

/edit
The same behavior in Firefox browser. MS Edge browser does display a graph but scaled incorrectly.

/edit2
A (hopefully temporarily) workaround for this: use the Grafana ‘Direct link rendered image’ option found in the Link tab on the Share Panel.

This basically creates a link to a rendered picture of the panel you want by adding ‘render/’ in the url. You can configure the numbers in the ‘&width=1000&height=500’ part of the url to suit your needs.

Of course you will need to remove the ‘&from=1544223600000&to=1544275759966’ part from the url to have it display the time frame you have set for the panel (it will refresh).

You loose the dynamic scalability of the panels though.

1 Like
#64

UPDATE 1.2.1 FIXED IT Thank you
In the latest update it looks like the iframe content is loaded while the iframe itself is set to invisible and report his height to 0 and that generate the issue on my attached image.

bug

Hope it help target the problem and fix it.

1 Like
#65

:tada: Release v1.2.1

This release upgrades Grafana to 5.4.1 :tada:, which fixes a lot of small bugs introduced in Grafana 5.4.0.

Full Changelog

  • Upgrades Grafana to 5.4.1

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck or https://buymeacoff.ee/frenck

4 Likes
#66

Thanks Frenck!
This update fixed my ‘Invalid dimensions for plot’ error as well. Graphs using the iframe share link are displayed as they did before update v1.2.0.

#67

I’m not sure if it’s a good place to ask but…
I use Hass.io with RPi3 & Grafana addon. I have separate RPi2 with MQTT broker & MySQL server [I use it for few things and also for HA recorder/history] and I use the MySQL HA recorder’s database as source for Grafana.

made a chart for my daily water usage - whenever my meter is working [water is flowing] an ESP with tasmota installed, publishes the meter’s readings via MQTT. then, I am comparing it with yesterday ones and have “today’s, current usage” as the outcome and the recorder puts this everytime to the database. so I have this in chart’s config:

FROM states
  Time column last_changed
  Metric column none
SELECT
  Column: state
  Aggregate: avg
  Alias: water daily
WHERE
  Macro: $__timeFilter
  Expr: entity_id = 'input_number.water_today'
GROUP BY time(1h, none)
Format as Time series

one that bothers me is the line “Aggregate”. knowing that during the day, every next readout of input_number.water_today is bigger than last one and it shows current daily usage summed up, I want my chart to use the maximum daily value of this sensor. unfortunately, when I choose “Agregate: MAX” then the chart is empty. “avg” option is mostly useable - the chart looks more logical, but values are not making any sense, because it averages every readout during the day, so it isn’t showing the real consumption.

is there anything I did wrong with above configuration, or “it’s not a bug, it’s a feature”? :wink:

#68

How did you get this to work? I’ve been looking long enough now so I have to eventually ask :slight_smile:

I’m trying to install this plugin.

Thanks in advance/hope.

#69

Dear,
I would like to run grafana from internet, without forwarding port in router,
Please guide me,
Thanks in adv.

#70

you’ll need to set up a reverse proxy or a create a VPN to your home network.

Here are two guides for the reverse proxy:

#71

Does linuxserver/letsencrypt work with armhf, as I had my hassio on rpi3b+.
Please guide

#72

i found linuxserver/letsencrypt for my raspberrypi which was lsioarmhf/letsencrypt.
i did with the process mentioned.
i find my folders created by docker but under /home/user/ltetsencrypt/etc/letsencrypt i dont find any ssl certs.
where are the certs located created by letsencrypt
pleaes guide

#73

I can’t make it work for me.
Do I need to install hassio addon: nginx and letsencrypt besides lsioarmhf/letsencrypt

#74

:tada: Release v1.2.2

Full Changelog

Changed

  • Fixes spelling error in Dockerfile
  • Removes BountySource links
  • Removes Anchore.io links
  • Updates maintenance year to 2019
  • Upgrades add-on base image to 2.2.1
  • Fixes build by removing unsupported i386
  • Configure Renovate (#21)
  • Replaces add-on link with GitHub link
  • Upgrades Grafana to 5.4.3

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck

#75

Hello. Good work on all the add-ons. I recently moved to Ubuntu from a pi and the Grafana plugin tells me it is not available for my system? Is there a way to tell the reason? I’m sure I missed something mentioned somewhere but I can’t find where. I am running hass.io in a docker container on Ubuntu 16.04.

Hardware:
Linux core-ssh 4.4.0-131-generic #157-Ubuntu SMP Thu Jul 12 15:49:15 UTC 2018 i686 Linux

#76

You are running a 32 bits Ubuntu. Grafana is not available for 32 bits Intel/AMD systems. (i386)

#77

That’s what I figured. Thanks for the info!

#78

I can’t make grafana to work from homeassistant outside my network without forwarding port on my router.
Please can some body guide,
I have installed hassio with docker on raspbian strech lite.
I want grafana to run from homeassistant, without forwarding/opening port 3000 to internet, from anywhere.
Is it possible to get it working?
Please guide

#79

:tada: Release v1.3.0

Full Changelog

Changed

  • Upgrades Grafana to 6.0.0
  • Upgrades add-on base image to 2.3.1

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck

#80

:tada: Release v2.0.0

Full Changelog

Changed

  • Update Grafana to v6.0.1 (#27) (@timmo001)
  • Upgrades add-on base image to 3.0.0
  • Drops legacy tag support
  • Replaces ARMHF support with ARMv7
  • Removes custom log format override
  • Makes log_level optional
  • Rewrite add-on onto Bashio
  • Makes Grafana wait for Memcached before starting
  • Fetch proper Grafana package for ARMv7
  • Fixes Grafana log level logic
  • Updates documentation for ARMv7

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck

1 Like