Home Assistant Community

Community Hass.io Add-on: motionEye

hassio-addon
hassio-repository
Tags: #<Tag:0x00007f3749f48418> #<Tag:0x00007f3749f482d8>
#19

Seems to be a hassio issue where tinker board support is missing

0 Likes

#20

It seems to be the problem of naming containers or ffmpeg binary file

0 Likes

#21

Correct, this is expected to be fixed in the next Hassio Supervisor release.

0 Likes

#22

I’m not sure what that means. My add-ons are build on native CPU services (e.g., the aarch64 add-on is build on a real aarch64/arm64 cpu/machine).

In the case of the aarch64 version of the add-on, the following package is installed by Alpine on installation of ffmpeg: https://pkgs.alpinelinux.org/package/v3.8/community/aarch64/ffmpeg

0 Likes

#23

Interesting, does this mean we have a better way of implementing the Xiaomi dafang cameras into hass now, without the laggy rtsp stream?

TJ

2 Likes

#24

Thanks @frenck, I was under the same impression but I can’t just manage to get LE running in my specific scenario. Would you mind taking a look at this old post of mine and let me know your thoughts on it? I used DuckDNS+Let’s Encrypt, but what I describe on it also applies to standalone LE add-on

I would appreciate it if you could point me in the right direction :slight_smile:

0 Likes

#25

How du you add an normal USB camera hooked up to a pi and with HASSIO on it?

0 Likes

#26

@Frenck: thanks for providing that add-on, really great work !

Is there a chance to get an HA event when a motion was detected (ideally with snapshot) ?

I’m aware that motionEye has the the detection option but I don’t wanna use the mail notification.

0 Likes

#27

There’s an option to send a webhook in motioneye. Just have it call a script

0 Likes

#28

I have motionEye running on another raspberry pi in my system. I assume there is not way to point to that machine to implement the Add-on? Having said that the Hassio install appears to run on Alpine Linux platform that does not have apt-get or pip commands implemented to install motionEye. Any leads are most appreciated.

0 Likes

#29

I can’t get this to run. What are the certfile and keyfile and where do I find them?

0 Likes

#30

If you don’t have ssl set ssl to false and then you’re done.

1 Like

#31

Yes, thats what I did. But by the time the script is executed and a snapshot has been taken, the object triggering the motion event has passed :frowning:

I need the motion- event with the correlating when the event was triggered

0 Likes

#32

Thank you teachingbirds, setting ssl to false has done it.
The motioneye is not coming up on the left panel though? I can open the “Web UI”, which opens on the HASSio IP address so everything appearst to be working… How do I get it do show in my left panel of HASS?

0 Likes

#33

Try reading the manual :wink:

1 Like

#34

:man_facepalming: Ooops sorry my bad.
I saw that but thought it was for including each camera into the “overview” tabs.

All working now…:blush:

0 Likes

#35

it works perfect , thankyou!

i wasnt able to make the camera push to work ,
https://www.home-assistant.io/components/camera.push/

this is in order to be able to capture or show , pictures , when an 2interest" event occurs .
the pictures are captured , but the push camera is not working , no idea if is a HASS problem , or some limitation on the addon .

0 Likes

#36

I have managed to find the RTSP URL’s for my two camera’s which are XMEYE cameras.

rtsp://admin:@192.168.0.104/user=admin_password=tlJwpbo6_channel=1_stream=0.sdp

rtsp://admin:@192.168.0.102/user=admin_password=tlJwpbo6_channel=1_stream=0.sdp

I can successfully open these steams in VLC.

However when I try and enter the URL in motionEYE it does not work.

Screenshot%20from%202018-10-20%2002-27-32

In the log files it returns the error:

/bin/sh: lsb_release: not found WARNING: 403 GET /login/?_=1539998503606&username=&_signature=529b3bacb79d310e280c6fae96a1464b0adbe478 (127.0.0.1) 5.97ms Failed to open /dev/video0: No such file or directory

Any ideas please?

0 Likes

#37

I’ve done the same, remove at the beginning “ admin:@“ leaving only the ip , this is mine:
rtsp://192.168.1.10/user=admin_password=tlJwpbo6_channel=1_stream=1.sdp

3 Likes

#38

@g.nigro Thank you very much! I would have never figured that out without your help.

0 Likes