Community Hass.io Add-on: motionEye

hassio-repository
hassio-addon
Tags: #<Tag:0x00007f203b8e7eb8> #<Tag:0x00007f203b8e7d50>

#41

Trying to install 0.2.0 and I get a message saying amd64 is not supported:

18-10-26 21:59:42 ERROR (MainThread) [hassio.addons.addon] Add-on a0d7b954_motioneye not supported on amd64

#42

Thanks for reporting this. Just to confirm, the add-on actually supports amd64.
This might just be an issue with the Hassio supervisor.
We found one before when someone tried installing it on an Odroid C2, which should be fixed already.

Could you please report this to the GitHub issue tracker for this add-on. Make sure to include all system information; especially your host system (device/board), system architecture, installation method (HassOS or generic Linux) and hassio version (the latest is currently v138).


#43

Earlier, I wrote about the problem on Orange PI Zero Plus2 (H5) on armbian.
As it turned out, I made a mistake when installing dockre-ce
It was necessary to put arch = arm64.
sudo add-apt-repository “deb [arch=arm64] https://download.docker.com/linux/ubuntu $(lsb_release -cs) stable”
I hope my mistake will help others.


#44

I seem to have been able to install the add-on without issues. When I open the UI, I get this error:

The connection to XXXX.duckdns.org:8765 was interrupted while the page was loading.

I have SSL set up using duckdns and letsencrypt. The port above is not the one I use. Do I need to set this port up for port forwarding also?

Thanks and kind regards,

Robert


#45

yes, you will need to forward that port in order to view the add-on page remotely (ie: via duckdns)


#46

Hi @hunterjm, could you please update to supervisor 139 and try to install it again?
The logs will now contain a little more info on why it didn’t install.


#47

Add-on a0d7b954_motioneye not supported on None with amd64 architecture

I am currently using a custom Home Assistant image that was set via the API.


#48

How can i save to google drive?


#49

OK, as I have recently migrated to HASSIO from hass, and have ZERO knowledge about docker containers, etc, can someone tell me how do I get to configuration folder for this addon?

What I mean is: normal installation of MotionEye has configuration folder in “/etc/motioneye/” and I need access it.
Need to drop some files there as it allows to have “action buttons” as a overlay in the video stream.

Any help appreciated


#50

@hede0n that is not yet supported by this addon.


#51

Right. I have just realised it is not going to work anyway as files I have mentioned are scripts to run mosquitto or curl commands. Do you think it would be possible to include curl in the docker image so we could use “action button” feature to control actions in HASS.IO?

BTW. thanks for your work man!


#52

@webhooks are supported, so you can point them to Home Assistant webhooks easily… from that point on… well anything is possible I guess


#53

Hi Frenck,
Thank you for another add-on! I have an error stating port 8082 is closed when I add my 6th ip camera and it ruins the rest of the 5 cameras. I read somewhere on the Github that changing the port number on the respective camera file located at etc/motioneye solved the problem. However, looking up here I see a folder created for each camera at share/motioneye but all the folders are empty. Could you please help me on this?


#55

I keep getting a “Please apply modified settings first” when trying to add a camera. The only change was changing the password to which I clicked the Apply button. Any suggestions?


#56

I am trying to add a network share to save my recording but I keep getting this error:

mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
   ERROR: failed to mount smb share "//****/Recordings" at "/media/motioneye_vddnetnas_vddnet_org_recordings_admin"
   ERROR: access to network share //****/Recordings failed: cannot mount network share

I have access to the share with the user configured.


#57

My motionEye has been running for quite a while and today I noticed it was not.

Upon reviewing the log, the following error is presented:

nginx: [warn] “ssl_stapling” ignored, issuer certificate not found for certificate “/ssl/certificate.pem”

I’m not sure I completely understand the error. The certificate.pem is in the SSL directory and has previously been running just fine. I am uploading a screen shot highlighting the location of the certificate.pem file.

Any ideas please?


#58

did you recently install nginx? I had to restart and change a few config setting for most of my addons after I switched to nginx for ssl. motioneye was one that wouldn’t work until I restarted it and logged in again

you might also consider creating an automation that checks if motioneye is running every few minutes and do a restart if it’s not. I’ve set this up for node red, but none of my other addons yet


#59

Hi!

I’m trying out the motionEye addon for my RPi3 running hassio. I’m trying to turn on and off the motion detection for the added cameras.

If I send a http request like “https://MYHASSIOIP.duckdns.org:8765/1/detection/start” I get this in the addon log:

ERROR: HTTP 404: Not Found (not found)
WARNING: 404 GET /1/detection (127.0.0.1) 3.95ms

I assume the request don’t work because the motionEye is not configured to accept http requests? I can’t seem to find any configuration file using WinSCP, I have serached for motion.conf and motioneye.conf.

Is it possible to turn on and off motion detection using http requests on hassio?


#60

#61

@2carlos Thank you very much for your reply. It was an issue with the certificates expiring. :slight_smile: