Home Assistant Community

Community Hass.io Add-on: MQTT Server & Web client

hassio-repository
hassio-addon
Tags: #<Tag:0x00007fcf48b912b0> #<Tag:0x00007fcf48b910f8>
#162

hey all - I am not exactly new to hassio or MQTT - but by sd card died about 2 weeks ago. Just got around to rebuilding - and the for life of me, I cannot get hassio to integrate with this add-on. I had a backup of my complete hassio config, rebuilt, installed and configured. This addon works OK, I can integrate with Node-Red, however the config for the hassio broker pointing to the this add-on just does not work. below was my config backup working config

mqtt:
  broker: a0d7b954-mqtt
  username: !secret mqtt_username
  password: !secret mqtt_password
  client_id: home-assistant

I just get an error when I try and publish to MQTT from hassio itself. I have external MQTT devices publishing just fine - any ideas?

my passwords are correctly configured in my secrets file.

#163

try using the IP instead of a0d7b954-mqtt

#164

Sir thank you for the reply - I tried to use the external IP of my RasPi, then ssh to the hassio and ping a0d7b954-mqtt which resolved to the internal docker IP - none of these work. This “did” work before my sd card died, also I had not updated hassio or the add-on for some time. Just curious if any recent updates “could” cause this type of issue?

#165

it could, the last couple of updates fixes issues with readonly and passwords

#166

Need some help with this add-on, I run it , Al looks fine, no issues in log files…
I start hivemq, can connect fine, button is green…
So I subscribe to #. , Just don’t see any messages if I test… Also not with other test tool like mqtt.fx…
Tried SSL , non SSL, anonymous…
If I try the other add-on without hivemq, everything is working perfectly…

I have no idea

#167

Make sure the user that is trying to publish do not have readonly: true

#168

yes, i can try that
but i also tried anonymous before, that should work always normally , no ?

#169

OMG, that was it , how simple can it be

#170

I installed the add-on. I’m starting “START”. If you want to enter Open web UI an error pops up.

Is there anything to write in Config? I have default settings. Please help. I’m a novice.

#171

change the host to your internal ip, probably your port is not forwarded in your router

#172

Check for clues in the addon log (same page that have the “OPEN UI” button)

#173

the same problem
hassio.local:5713 and 192.168.1.29:5713

#174
[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-banner.sh: executing... 
-----------------------------------------------------------
 Hass.io Add-on: MQTT Server & Web client v0.3.1
 Mosquitto MQTT Server bundled with Hivemq's web client
 From: Community Hass.io Add-ons
 By: Franck Nijhof <[email protected]>
-----------------------------------------------------------
 aarch64 / HassOS 1.13 / HA 0.85.0 / SU 141 / stable
-----------------------------------------------------------
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
Log level is set to INFO
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 02-updates.sh: executing... 
INFO: You are running the latest version of this add-on
[cont-init.d] 02-updates.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing... 
FATAL: The configured certfile is not found
[cont-init.d] 10-requirements.sh: exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] 99-message.sh: executing... 
-----------------------------------------------------------
                Oops! Something went wrong.
 
 We are so sorry, but something went terribly wrong when
 starting or running this add-on.
 
 Be sure to check the log above, line by line, for hints.
-----------------------------------------------------------
[cont-finish.d] 99-message.sh: exited 0.
[cont-finish.d] done.
[s6-finish] syncing disks.
[s6-finish] sending all processes the TERM signal.`Preformatted text`
#175

This will be why :slight_smile:

#176

Hi, I have my MQTT Server Add-ON setup and working fine but when rebooting the host, the service MQTT Server doesn’t load fast enough for HA to connect and cause all MQTT entities to not load. If I restart the HASS service after the reboot everything work fine.

homeassistant.exceptions.HomeAssistantError: Error talking to MQTT: The client is not currently connected.

I found this thread talking about services config file to let HA know which services need to be load before launching HA. How can we access this file with HASSIO?

#177

Interested, same issue here… If I do full reboot, I always need to restart first HA upon first boot :wink:

1 Like
#178

@pergola.fabio I have submit a bug issue.

#179

:arrow_up: v1.0.0

#180

:arrow_up: v1.0.1

#181


What options do I put here? I have tried all the ports, IP (10.10.1.13), hostname (a0d7b954-mqtt) and SSL/non-SSL.

I get this error:
image

Add-on Config:

{
  "log_level": "info",
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "web": {
    "enabled": true,
    "ssl": false
  },
  "broker": {
    "enabled": true,
    "enable_ws": false,
    "enable_mqtt": true,
    "enable_ws_ssl": true,
    "enable_mqtt_ssl": true,
    "allow_anonymous": false
  },
  "mqttusers": [
    {
      "username": "mqttuser",
      "password": "my-password",
      "readonly": false,
      "topics": [
        "#"
      ]
    }
  ]
}

configuration.yaml:

mqtt:
  broker: a0d7b954-mqtt
  port: 1883
  username: mqttuser
  password: my-password
  client_id: mqtt-home-assistant