Community Hass.io Add-on: Node-RED

hassio-repository
hassio-addon
Tags: #<Tag:0x00007f2050f65078> #<Tag:0x00007f2050f64d80>

#446

Im getting this on my node-red logs, any ideas?

30 Oct 23:22:51 - [info] Starting flows
30 Oct 23:22:52 - [info] Started flows
30 Oct 23:22:52 - [info] [mqtt-broker:Mosquitto] Connected to broker: mqtt://localhost:1883
30 Oct 23:22:52 - [info] [server:Home Assistant] WebSocket Connected to http://hassio/homeassistant
30 Oct 23:22:52 - [error] [function:Compose weather] TypeError: Cannot read property 'state' of undefined
30 Oct 23:22:52 - [error] [function:Compose temperature] TypeError: Cannot read property 'state' of undefined
30 Oct 23:22:52 - [error] [function:Compose weather] TypeError: Cannot read property 'state' of undefined
30 Oct 23:22:52 - [error] [function:Compose temperature] TypeError: Cannot read property 'state' of undefined

#447

Please read the release notes (posted yesterday in this thread) on the upgrade instructions.


#448

Ah ok, seems like there are some breaking changes with two of the nodes. The Poll State and Current State both have a little different formatted output. im working on it, thanks @frenck


#449

When using Ha services, code-red contains node-red-contrib-home-assistant-websocket errors. How to fix? or how to update? Ha installed in Docker!


#450

So, I see in the notes that “the add-on now authenticates against Home Assistant”. But what is my username? I have the api_password set, and that’s all I’ve ever used to login to home assistant. and now I can’t access node red at all, I tried blank user and ‘admin’, but I can’t even see in the docs where to configure a potential username for home assistant?


#451

me2 too i have delete the folder .store, restart and set a new user. but node-red said “Login failed”. After delet node-red incl. folder, the same. something I’m doing wrong


#452

So, the answer for me was, upgrade to a newer home assistant, since apparently users are a thing now, but weren’t on the version I was using.

The new home assistant config was automatically added, but didn’t replace my existing one, so on every node I had 2 “Homeassistant” options to choose as the server. I just deleted the old one, and had to double-click then click done on every HA node to reset it to the new server config using the generated key, and now it appears to be working again.


#453

I upgraded to the new Node-RED, reconfigured and made sure everything worked smoothly. Tonight I updated my Hassio to HassOS 1.12 then Hass to 81.2. After the system came back online I noticed in the Hass System Log a whole bunch of errors when Node-RED was trying to initialize the API.

18-10-31 00:12:47 INFO (MainThread) [hassio.api.proxy] Home Assistant WebSocket API request initialize
18-10-31 00:12:47 INFO (MainThread) [hassio.api.proxy] WebSocket access from a0d7b954_nodered
18-10-31 00:12:47 ERROR (MainThread) [hassio.api.proxy] Client error on WebSocket API Cannot connect to host 172.30.32.1:8123 ssl:False [Connection refused].

There wasn’t any errors anywhere else and my automations wouldn’t work until I restarted Node-RED. After restarting Node-RED everything was fine again.


#454

After upgrading Node-red started to appear such mistakes all the options Ha


#456

I keep getting this error no matter what I try…

31 Oct 17:42:23 - [error] [server:Home Assistant] Error: Invalid access token or password.

I have tried to uninstall and reinstall the add-on and reset all settings to default without any luck…

My config looks like this:
{
“log_level”: “info”,
“credential_secret”: “(same credential as before the upgrade”,
“http_node”: {
“username”: “”,
“password”: “”
},
“http_static”: {
“username”: “”,
“password”: “”
},
“port”: 1880,
“ssl”: true,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“require_ssl”: true,
“system_packages”: [],
“npm_packages”: [],
“init_commands”: []
}


#457

Please edit your server connection in NodeRed.
it has to be changed to :
http://hassio/homeassistant as the server URL
No access token necessary

See last item on upgrade instructions :


#458

:tada: Release v1.0.1

Full Changelog

Changed

  • Upgrades Node-RED to 0.19.5
  • Adds FAQ’s about upgrading to v1.x.x

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck


#459

I note that I had to specify the username in lowercase in order to get this to work, despite having mixed-case usernames in HA.

Config as per @TKDJesper is working for me if I use the username incorrectly with lowercase from HA


#460

I’ve tested this (again just right now to be sure), but the add-on handles casing of usernames correct on my end.
I’ve tested with the username Henk and password }_zmq4c.%CXbqh>/B9"2Dmq%,!Am)v"^+pJ~qEjLv’[gF$`. So both complex password an capitalized usernames, did work on my end?


#461

Hi Frenck…
I solved the issue with only lower case letters…
In Home Assistant the users is registered with a capital letter, but if I write the exact name as it is in HA, I get a login failed… If I only use lower case letters, then all is fine…


#462

The Users’ name is registered with a capital letter, the username is lowercase (automatically suggested by HA).


#463

All went well except that the new problem is that now HA does not connect to node-red there is no data in the API pass and Long-Lived Access Token. That there to point fingers? Before the update, the data were registered there.


#464

Not sure what you are using, but that is not what the add-on should look like (your fields are different).

image

Seems like you have a manually installed/loaded version of the Spartan-II-117 fork installed.


#465

Don’t know for sure but in manual I didn’t installed all the repository HA after the update this has become.


#466

Go to the palette management and search for home-assistant, what do you see?