Community Hass.io Add-on: Node-RED

hassio-repository
hassio-addon
Tags: #<Tag:0x00007f203bc944a8> #<Tag:0x00007f203bc94368>

#489

Hi All… question… could it be that the DELTA node had been there and lost in version 1.0.0?
After upgrading I noticed my flows were broken because this node is not being recognized… don’t remember installing it specifically before…
Tried to solve by installing node-red-contrib-delta-timed, but does not seem to be the same.

Thanks for your help.
ET


#490

That is impossible, that node has never been part of the add-on. Check GitHub in case you doubt my judgement :wink:


#491

Hi, I quite like this addon, it’s working well for me.

Just q quick question, I don’t really or need all the extra nodes that have been added, is there a way to set it back to the stock ones you get with a fresh node-red install?

I tried to remove some of them in the palette manager but I could only disable them, there is no remove option.

Thanks


#492

The answer is kinda: No. The add-on was designed to be a great starting point for new and existing users. But I can see why you would remove some parts. You can run custom commands using the init_commands setting and change the environment to your liking.

Docs:


#493

I also see this… delta was showing in my node red before 1.0, doesnt now. Thanks for all your great work on this.


#494

Hi All, i have been pulling my hair out for the last 24 hours. My wife is on my back cos none of the lights are working.m :slight_smile: Was working perfectly with Hassio 0.81.5 and nodered. I updated to the latest Hassio, now after a few minutes nodered crashes and doesn’t come back up.

[email protected] start /opt
node $NODE_OPTIONS node_modules/node-red/red.js “–settings” “/etc/node-red/config.js”

Error loading settings file: /etc/node-red/config.js
TypeError: Cannot read property ‘length’ of undefined
at Object. (/etc/node-red/config.js:27:19)
at Module._compile (module.js:635:30)
at Object.Module._extensions…js (module.js:646:10)
at Module.load (module.js:554:32)
at tryModuleLoad (module.js:497:12)
at Function.Module._load (module.js:489:3)
at Module.require (module.js:579:17)
at require (internal/module.js:11:18)
at Object. (/opt/node_modules/node-red/red.js:115:20)
at Module._compile (module.js:635:30)


#495

Warning: totally newbie
Hello,
I just installed Hassio on rp3 and added Node-Red from the community repository,
in order to read rflink gateway data from the serial port.
The problem is that there is no serial input node.
How can I add serial support?
Found node-red-node-serialport on the palette, but it failed to install.
I tried npm i node-red-node-serialport before but that also failed.
It said: -bash: npm: command not found
Please help!
Wim (Sorry for xposting this in Home Assistant Forum.)


#496

Hi,
I have a strange problem, i tried node-red a couple of weeks ago and then uninstalled it.
Today i installed it again with a different password. For some reason it only accepts the password i used from the first install.
It seems the save config does not overwrite the config file.

{
“log_level”: “info”,
“credential_secret”: “password”,
“http_node”: {
“username”: “username”,
“password”: “password”
},
“http_static”: {
“username”: “username”,
“password”: “password”
},
“port”: 1880,
“ssl”: false,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“require_ssl”: false,
“system_packages”: [],
“npm_packages”: [],
“init_commands”: []
}


#497

:tada: Release v1.1.0

Full Changelog

Changed

  • Adds make & g++ to speed up build times
  • Upgrades node-red-contrib-bigtimer to 2.0.3
  • Upgrades node-red-contrib-interval-length to 0.0.3
  • Upgrades bluebird to 3.5.3
  • Upgrades node-red-contrib-home-assistant-websocket to 0.2.0
  • Markes package.json as a private repository

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck or https://buymeacoff.ee/frenck


#498

Thanks again @frenck , works seamlessly.


#499

Installed the add-on and started with no problem on the log but this is what I get on the screen…

image

… tried to uninstall and reinstall many times, but the result is the same; tried also with different browser and devices with no luck.

Looking at the path of one the missed image it point to http://192.168.1.14:1880/red/images/spin.svg but I’ve no “red” folder on my www of HASS.io installation.

And the following is my log:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-banner.sh: executing... 
-----------------------------------------------------------
 Hass.io Add-on: Node-RED v1.1.0
 Flow-based programming for the Internet of Things
 From: Community Hass.io Add-ons
 By: Franck Nijhof <[email protected]>
-----------------------------------------------------------
 amd64 / HassOS 1.12 / HA 0.82.1 / SU 139 / stable
-----------------------------------------------------------
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
Log level is set to INFO
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 02-updates.sh: executing... 
INFO: You are running the latest version of this add-on
[cont-init.d] 02-updates.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing... 
INFO: Password is NOT in the Have I Been Pwned database! Nice!
INFO: Password is NOT in the Have I Been Pwned database! Nice!
[cont-init.d] 10-requirements.sh: exited 0.
[cont-init.d] 20-config.sh: executing... 
[cont-init.d] 20-config.sh: exited 0.
[cont-init.d] 80-system-packages.sh: executing... 
[cont-init.d] 80-system-packages.sh: exited 0.
[cont-init.d] 81-npm-packages.sh: executing... 
[cont-init.d] 81-npm-packages.sh: exited 0.
[cont-init.d] 82-user-scripts.sh: executing... 
[cont-init.d] 82-user-scripts.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
> [email protected] start /opt
> node $NODE_OPTIONS node_modules/node-red/red.js "--settings" "/etc/node-red/config.js"
19 Nov 20:05:39 - [info] 
Welcome to Node-RED
===================
19 Nov 20:05:39 - [info] Node-RED version: v0.19.5
19 Nov 20:05:39 - [info] Node.js  version: v8.12.0
19 Nov 20:05:39 - [info] Linux 4.14.78 x64 LE
19 Nov 20:05:40 - [info] Loading palette nodes
19 Nov 20:05:40 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
19 Nov 20:05:41 - [info] Settings file  : /etc/node-red/config.js
19 Nov 20:05:41 - [info] Context store  : 'default' [module=memory]
19 Nov 20:05:41 - [info] User directory : /config/node-red/
19 Nov 20:05:41 - [warn] Projects disabled : editorTheme.projects.enabled=false
19 Nov 20:05:41 - [info] Flows file     : /config/node-red/flows.json
19 Nov 20:05:41 - [info] Starting flows
19 Nov 20:05:41 - [info] Started flows
19 Nov 20:05:41 - [info] Server now running at http://127.0.0.1:1880/
19 Nov 20:05:41 - [info] [server:Home Assistant] WebSocket Connected to http://hassio/homeassistant

Any idea?


#500

-I have a Home Assistant in a secure network and I use Node-RED and others Add-Ons, and they always break the run the add-ons for Pwned database warning.

-I want to disable this Pwned check for all add-ons

Any idea…?


#501

Hi Eddie1974, did you ever get this solved.

I am suffering the same problem, ever since I upgrade to version 1.0
I can restore from an old snapshot, and Node Red will work, until I update the Addon. Then I am back to the same error message

Anyone got any ideas what the error message means. Does it mean the config.js is corrupt, or missing ?


#502

You are probably still running the ResinOS version of Hassio. Please upgrade to HassOS.


#503

Hi frenck, thanks for the advice.

Unfortunately in this case I’ve been running the qemux86-64 docker version, with both supervisor and HA containers for about 2 months.

Is there anything I can check to help identify the root cause


#504

Have you read the release notes for v1.0.0?


#505

It’s me not you Frenck…

I was testing an import from a tutorial and now all my flows no longer work.

It says “Flows stopped due to missing dependencies” sqlitedb

I deleted the flow but the error continues.

Any suggestions before I delete everything and start again?

If I do delete I assume I just export my current flows and after reinstall import them in?

Sorry for being a pain.

Hans


#506

Hello,

first of all thanks for the add-on.

However I’m having some issues with it. On some flows the flow stops on the first flow or it sends the wrong service to home assistant.

Here’s an example:

that LRL1 - light should blink when I receive a call on my phone (through automate and a binary sensor). However it just turns on the light but doesn’t turn it off (turn off is selected as the service). Under the node it says light.turn_on was called (even though turn_off was selected as a service)

I have similar issues with other flows where some services don’t get called (happens with parallel and serial nodes).

thanks


#507

Hi Community,
I’m a newbie looking for some help with NR v1.1.0 connecting to Hassio.HA v0.82.1 using the “node-red-contrib-home-assistant” Palette. From this thread it seems like a good number of you have experience this issue.

[error] [server:Home Assistant] Home assistant connection failed with error: Connection to home assistant could not be established with config: https://192.168.1.x:8123/ password redacted

I’ve tried using no password, the password in the configuration.yalm, as well as the password i’m now using to logon…unfortunately none seem to work. Any help with this issue would greatly be appreciated.

On a related note, I was wondering is there a way to setup certificate authentication or other that did not require a password.

Thanks


#508

@mendezg
are you using the right username?