Community Hass.io Add-on: Pi-hole

hassio-repository
hassio-addon
Tags: #<Tag:0x00007fd08a5d8380> #<Tag:0x00007fd08a5d8128>

#207

I am having the same issue.
My current sensor configuration is the following:

- platform: pi_hole
  host: 192.168.178.101:8080

It worked at some point, but stopped working after one (of many) restarts.
I am currently running on 0.73.1
The log states the following:

Error while setting up platform pi_hole
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/homeassistant/helpers/entity_platform.py", line 129, in _async_setup_platform
    SLOW_SETUP_MAX_WAIT, loop=hass.loop)
  File "/usr/lib/python3.6/asyncio/tasks.py", line 358, in wait_for
    return fut.result()
  File "/usr/lib/python3.6/site-packages/homeassistant/components/sensor/pi_hole.py", line 89, in async_setup_platform
    await pi_hole.async_update()
  File "/usr/lib/python3.6/site-packages/homeassistant/components/sensor/pi_hole.py", line 170, in async_update
    await self.api.get_data()
  File "/usr/lib/python3.6/site-packages/hole/__init__.py", line 44, in get_data
    self.data = await response.json()
  File "/usr/lib/python3.6/site-packages/aiohttp/client_reqrep.py", line 936, in json
    return loads(stripped.decode(encoding))
  File "/usr/lib/python3.6/json/__init__.py", line 354, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.6/json/decoder.py", line 339, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.6/json/decoder.py", line 357, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

So maybe it is rather an issue with HA?


#208

I’m experiencing the same issue with android.clients.google.com, resulting in problems with the play store and the inbox app. I can see the URL on my whitelist, but being blocked in the query log as well. Any ideas?


#209

Hey @frenck, I’ve created a new “website blocked” page for me, where’s located the default index.php file?


#210

Modifying the sources is not supported by the add-on.


#211

Restart / reload DNSMasq from the Pi-hole settings.


#212

Just updated to the latest hassOS and getting this error:

Opening of FTL log (/var/log/pihole-FTL.log) failed!
Make sure it exists and is writeable by user pihole

Everything was working fine before I did the update, can anyone help with a resolution to this problem?

edit
Seems the logfile had been deleted, now working after a reinstall.

Thanks


#213

:tada: Release v1.3.0

Full Changelog

Fixed

  • Fixes incorrect FTL log file permissions

Changed

  • GitLab CI now using the latest Hadolint
  • Upgrades base image to v2.0.1
  • Upgrades gcc to 6.4.0-r8
  • Upgrades make to 4.2.1-r2
  • Upgrades musl-dev to 1.1.19-r10
  • Upgrades bind-tools to 9.12.1_p2-r0
  • Upgrades coreutils to 8.29-r2
  • Upgrades dnsmasq-dnssec to 2.79-r1
  • Upgrades git to 2.18.0-r0
  • Upgrades grep to 3.1-r2
  • Upgrades libxml2 to 2.9.8-r0
  • Upgrades logrotate to 3.14.0-r0
  • Upgrades ncurses to 6.1-r0
  • Upgrades openssl to 1.0.2o-r1
  • Upgrades PHP to 7.2.7-r0
  • Upgrades procps to 3.3.15-r0
  • Upgrades sed to 4.4-r2
  • Upgrades sudo to 1.8.23-r2

Removed

  • Removes the creation of the dnsmasq user, no longer needed

#214

Restart / reload DNSMasq from the Pi-hole settings.

That doesn’t fix it. Whitelist still isn’t working for me.


#215

Any recommended lists for blocking besides built in lists?

With just built in lists I got 126K sites on blocklist but not sure if this is enough (for examle Youtube ads not blocked so I still use uBlock Origin), found this list with about 3Mil sites but this is overkill, takes too long for RPi to load and blocks also needed sites, here it is if anyone interested:


Source is trusted, he is developer and/or admin on Pi-Hole forums

I’m curious if people use just built in lists or add additional lists, and if there is a solution to Youtube ads


#216

I have my Pi-Hole installed and running and it all looks good but I see no stats. Also, on the test ad pages they load without ads and then a while later the ads appear.

Restarting Pi-Hole will fix this for a minute or two but then they come back.

The status always shows active and I’m just using default settings.

Any ideas where to look?


#217

I too am having the issue: “dnsmasq: failed to create listening socket for port 53: Address in use”

Any thoughts on how to resolve?

EDIT: Solved. Commented out dnsmaq in network-manager


#218

I am having the exact same error and the Pi-hole sensors have disapperared. Just updated Hassio to 0.74.2. Any ideas how to solve this?


#219

I’m still not having any success with this.

I’ve started with a fresh install of HASS.io and Pi-Hole.

Here’s what I’m seeing:

So, it looks like it’s active but not doing anything.

When I check the test page I see this:

So, I know it’s not working.

My config looks like this:

Voila_Capture%202018-07-30_01-50-36_pm

and the log like this:

I’d really appreciate any help to get this working.


#220

Did you set up your DNS settings on your router/pc correctly to the IP address of your Raspberry Pi?


#221

Thanks for the help.

Do you mean like this?

Screen2018-07-30_04-03-46_pm

I didn’t know it was necessary to change anything in the router. What difference will this make to my network?


#222

Yes, right there. If your Raspberry Pi got an IPv6 as well you can add that too.
If you set it on the router itself, all devices on your network will use it as DNS server instead of only the devices you set it on.


#223

OK. If I set it like that I lose internet access.

Setting my Mac DNS to 10.0.1.32 (my pi) enables Pi-Hole, but just for the Mac, so it does work.

I just need to get it set correctly on my router.

Screen2018-07-30_10-09-18_pm


#224

I’m having a weird issue when if Pihole is running while Hassio restarts, my Wink & Nest components dissapear. If I stop Pihole, restart, everything shows up again. I have tried re-installing Pi-hole and it even happens on a fresh install of Hassio.


#225

Spoke too soon. “dnsmasq: failed to create listening socket for port 53: Address in use” error still happening

No idea how to resolve


#226

Just means that some other application is using this port. Check your other addons what Port they are using.