Community Hass.io Add-on: Pi-hole

hassio-repository
hassio-addon
Tags: #<Tag:0x00007fd075921c40> #<Tag:0x00007fd075921a10>

#227

Only other thing is DuckDNS - would that be the problem?


#228

Could be, just check what Port it is using. And then maybe change 53 to 54 or anything else thats not used up.


#229

Any plans to update this add on to v4? Ta


#230

I’ve already started on the upgrade the day it came out, not sure about an ETA. Changes to v4 are pretty big.


#231

Curious what others think to the performance overhead of this on a Pi3? I already have HassIO and about to install the UniFi controller and piHole. DOn’t want to overload my little Pi :slight_smile:


#232

The current Pi-hole is pretty low on resource consumption. Furthermore, v4, will be consuming less. Nevertheless, I all depends on a lot of factors. E.g., automations and components used e.d…


#233

I don’t expect any problems. I’ve only been running it on a Pi3 for a few days, but I’ve run it for months on a Pi2 previously. I haven’t used the UniFi controller, but when I first installed Pi-hole, there wasn’t a discernible performance hit.


#234

Hey guys… a little help, please.

I’m running HassOS on a static IP, and DNS servers pointing to google. My Pi-hole is up and running and I have both DNS and DHCP enabled, but somehow I still can’t access HA using my DuckDNS domain. I thought once I set the static IP to the RPi3 this would be solved, but that’s not the case.
How can I solve this?

Thanks in advance.


#235

Many thanks for this add-on, working great when I use my default dns settings on my mac. I use a smart dns proxy to bypass geo-restrictions, I’ve tried adding the relevant dns address to the upstream settings in the pi-hole web interface but this doesn’t work. Any pointers for what I need to do?


#236

What version of Pi-hole is used??


#237

The current stable version for the add-on is Pi-hole v3.3.1, Pi-hole v4 is currently under development.


#238

At the moment it uses the latest Pi-hole core v3, so that’s 3.3.1
Dashboard v3.3 and FTL engine v3.0, the more you know.
V4 of Pi-hole is currently under development to work as a Hass.io add-on.

Edit: seems like Franck beat me to it :exploding_head:


#239

Thanks, then I wait for that version. The Pi-hole is very different in v.4


#240

Well, it’s not that different. You could easily install it now and just update later.


#241

The add-on will provide a single click upgrade path @Yuran


#242

OK thank you


#243

Hi,

I need a bit of help, I am new to Hassio but slowly getting things done. WAF is going up as well, so I reckon I am on good tuck. But bragging aside I have installed PiHole, it is working as expected (but still android phone YouTube is getting ads sometimes), I have a few list and suddenly I can’t open two sides: aliexpess and gearbest. I tried to add this to whitelist but no luck, I got DNSthingy addon to Chrome but probably do not know which kind of information to look for. Can anybody help me please?

Cheers


#244

Recently, I started exploring more advaced things that I can do with HA and I stumble across Pi Hole. I have installed latest addon (1.3) and confirgured it to best of knowledge as below. When In click open wed interface I get below UI and I am not sure what username / password to use there. Any comments / feedback highly appriciated.

My addon configuration is listed below along with logs that I get when I start the addon.

Configuration

{
  "log_level": "info",
  "password": "password",
  "update_lists_on_start": true,
  "http_port": 80,
  "https_port": 443,
  "dns_port": 53,
  "ssl": false,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "interface": "",
  "ipv6": true,
  "ipv4_address": "",
  "ipv6_address": "",
  "virtual_host": "https://xxxxx.duckdns.org:8123/",
  "hosts": []
}

Logs on start up

-----------------------------------------------------------
 Hass.io Add-on: Pi-hole v1.3.0
 Network-wide ad blocking using your Hass.io instance
 From: Community Hass.io Add-ons
 By: Franck Nijhof <[email protected]>
-----------------------------------------------------------
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
Log level is set to INFO
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 02-updates.sh: executing... 
INFO: You are running the latest version of this add-on
[cont-init.d] 02-updates.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing... 
[cont-init.d] 10-requirements.sh: exited 0.
[cont-init.d] 11-patches.sh: executing... 
[cont-init.d] 11-patches.sh: exited 0.
[cont-init.d] 11-pihole.sh: executing... 
[cont-init.d] 11-pihole.sh: exited 0.
[cont-init.d] 12-dnsmasq.sh: executing... 
[cont-init.d] 12-dnsmasq.sh: exited 0.
[cont-init.d] 13-nginx.sh: executing... 
[cont-init.d] 13-nginx.sh: exited 0.
[cont-init.d] 14-password.sh: executing... 
  [✓] New password set
[cont-init.d] 14-password.sh: exited 0.
[cont-init.d] 15-hostname.sh: executing... 
[cont-init.d] 15-hostname.sh: exited 0.
[cont-init.d] 16-logfiles.sh: executing... 
[cont-init.d] 16-logfiles.sh: exited 0.
[cont-init.d] 17-hosts.sh: executing... 
[cont-init.d] 17-hosts.sh: exited 0.
[cont-init.d] 50-gravity.sh: executing... 
  [i] Neutrino emissions detected...
  [i] Pulling blocklist source list into range...

  [✓] Pulling blocklist source list into range
  [i] Target: raw.githubusercontent.com (hosts)
  [i] Status: Pending...

  [✓] Status: Retrieval successful
  [i] Target: mirror1.malwaredomains.com (justdomains)
  [i] Status: Pending...

  [✓] Status: No changes detected
  [i] Target: sysctl.org (hosts)
  [i] Status: Pending...

  [✓] Status: No changes detected
  [i] Target: zeustracker.abuse.ch (blocklist.php?download=domainblocklist)
  [i] Status: Pending...

  [✓] Status: No changes detected
  [i] Target: s3.amazonaws.com (simple_tracking.txt)
  [i] Status: Pending...

  [✓] Status: No changes detected
  [i] Target: s3.amazonaws.com (simple_ad.txt)
  [i] Status: Pending...

  [✓] Status: No changes detected
  [i] Target: hosts-file.net (ad_servers.txt)
  [i] Status: Pending...

  [✓] Status: No changes detected
  [i] Consolidating blocklists...

  [✓] Consolidating blocklists
  [i] Extracting domains from blocklists...

  [✓] Extracting domains from blocklists
  [i] Number of domains being pulled in by gravity: 159002
  [i] Removing duplicate domains...

  [✓] Removing duplicate domains
  [i] Number of unique domains trapped in the Event Horizon: 135752
  [i] Nothing to whitelist!
  [i] Parsing domains into hosts format...

  [✓] Parsing domains into hosts format
  [i] Cleaning up stray matter...

  [✓] Cleaning up stray matter
  [✗] dnsmasq: no process found
pihole-FTL: no process found
  [✓] DNS service is running
  [✓] Pi-hole blocking is Enabled
[cont-init.d] 50-gravity.sh: exited 0.
[cont-init.d] 99-tests.sh: executing... 
dnsmasq: syntax check OK.
[21-Aug-2018 23:52:25] NOTICE: configuration file /etc/php7/php-fpm.conf test is successful
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful
[cont-init.d] 99-tests.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

#245

Did you forward port 80?
Otherwise I would guess this is not Pi-hole you’re accessing, but your router/modem.
Try using http://YOUR_PI_IP_ADDRESS/admin/.


#246

:tada: Release v2.0.0

This is a big/major release and upgrades Pi-hole to v4.0!

:warning: Breaking changes

There are some changes that from the 1.x series of the add-on.

  • Pi-hole now uses NULL based routing, the “Blocked” page is therefore no longer needed/available.
  • http_port and https_port have been replaced with admin_port.
  • The default port for the admin interface is now: 4865
  • SSL is now enabled by default, you need to disable it manually in case you don’t use SSL.
  • Setting as password for authentication is now enforced.

Full Changelog

Added

  • Pi-Hole FTL v4.0 patches
  • Adds default block list
  • Adds Pihole FTL config
  • Adds default DNSMasq configuration
  • Adds Pihole vX -> v4 migration script
  • Adds admin port support to NGinx

Fixed

  • Fixes reloading of DNS on white/blacklist changes (#33)
  • Patches pihole-FTL.conf to not break the admin interface

Changed

  • Upgrades base image to v2.1.2
  • Sets default Shell
  • Enforces authentication and HaveIBeenPwned checks
  • Updates README and links
  • Upgrades OpenSSL to 1.0.2o-r2
  • Upgrades PHP to 7.2.8-r1
  • Enables SSL by default
  • Upgrades ncurses to 6.1_p20180818-r0
  • Replaces dnsmasq with pihole-FTL
  • DNS container init move and migration
  • Changes order of container init
  • Updated forum link
  • Updates README to match recent changes

Removed

  • Removes DNSMasq
  • Removes Pihole Block page, moving to NULL based blocking

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck