Home Assistant Community

Community Hass.io Add-on: Pi-hole

hassio-addon
hassio-repository
Tags: #<Tag:0x00007fcf4cf3b240> #<Tag:0x00007fcf4cf3b100>
#367

This Worked for me too, thank you!

#368

I need some assistance configuring the Pi-hole addon. I’m running Centos 7. When I start Pi-hole, it starts up fine but I’m getting this error in my log:

dnsmasq: failed to create listening socket for port 53: Address in use

I’ve determined that dnsmasq is part of NetworkManager for Centos 7 and is already running. Is there a way I can configure Pi-hole to use the already running dnsmasq?

#369

Disable the service on centos 7 that is utilising port 53. Then pi-hole will be able to establish a listening socket. Ran into the same thing recently on ubuntu.

#370

When will the addon be updated to the newest version of pihole 4.2.2.

Currently the addon is at 4.1-dirty

How long does it usually take to get to the newest version?

#371

Hi everyone, I’m trying to get some of the hosts to show names instead of IP addresses.
Add the config, saved and restarted, but no cigar. Still IP addresses.

What I am doing wrong?

{
"log_level": "info",
"password": "***",
"update_lists_on_start": false,
"admin_port": 4865,
"dns_port": 53,
"ssl": true,
"certfile": "fullchain.pem",
"keyfile": "privkey.pem",
"interface": "",
"ipv6": true,
"ipv4_address": "",
"ipv6_address": "",
"virtual_host": "***",
"hosts": [
    {
        "name": "echo-bedroom",
        "ip": "192.168.1.180"
    },
    {
        "name": "echo-livingroom",
        "ip": "192.168.1.114"
    },
    {
        "name": "nvidia-shield",
        "ip": "192.168.1.122"
    },
    {
        "name": "tv-livingroom",
        "ip": "192.168.1.40"
    }
]

}

#372

Can you be a bit more specific?
From where do you want them to show name instead of ip and are you 100% sure the pi-hole is used for dns on that system.

#373

Sorry. I thought it was clear.

Yes, everything is working fine regarding functionality.
I just want to have custom names on the frontend for devices that either reporting only IP or the ones which have an unfriendly name and I can’t change it on the device (Echo devices, for example).

But most devices do show in the frontend with proper names.

Did I understand incorrectly that the hosts config was meant for custom names?

#374

I dont know where pi-hole gets the name from. But the Hosts is just a regular static dns record, like if you want to use split dns for reaching internal IP of your HA with the same FQDN as whenn outside you can put the same FQDN and the internal IP.
Or if you put pornhub.com you can get it to direct to your local server :wink:

#375

are we talking about the same thing?

Per documentation:
This option allows you create your own DNS entries for your LAN. This capability can be handy for pointing easy to remember hostnames to an IP (e.g., point printer.local to the IP address of your printer).

#376

As per the messages above, I’ve set a static DNS and IP for my Pi to get around network issues, but I’m still having them. Google TTS requests fail as do Darksky API requests. Any ideas what’s going on?

#377

Is it possible to use Pi-hole iframe with Caddy reverse proxy?

I have tried both ssl: true and ssl: false in combination with http and https in iframe url and none of these settings works correctly. I can still acces Pi-hole admin page from local network through my local Pi adress:4865.

configuration.yaml

panel_iframe:
  pihole:
    title: Pi-hole
    icon: mdi:block-helper
    url: https://pihole.MYSUBDOMAIN.duckdns.org

Caddy config:

pihole.MYSUBDOMAIN.duckdns.org {
    proxy / 192.168.xxx.xxx:4865 {    #(tried also /admin/ at the end of url)
        websocket
        transparent
    }

Other addons (eg. Tasmoadmin) configured in this way are working without any issues.

#378

:tada: Release v3.0.0

Full Changelog

Changed

  • Removes BountySource links
  • Removes Anchore.io links
  • Updates maintenance year to 2019
  • Refactor of GitLab CI
  • Upgrades wget to 1.20.1-r0
  • Configure Renovate (#58)
  • Upgrades add-on base image to 3.0.0
  • Upgrades gcc to 8.2.0-r2
  • Upgrades musl-dev to 1.1.20-r3
  • Upgrades linux-headers to 4.18.13-r1
  • Upgrades nettle-dev to 3.4.1-r0
  • Upgrades coreutils to 8.30-r0
  • Upgrades git to 2.20.1-r0
  • Upgrades libcap to 2.26-r0
  • Upgrades libxml2 to 2.9.9-r1
  • Upgrades logrotate to 3.15.0-r0
  • Upgrades ncurses to 6.1_p20190105-r0
  • Upgrades openssl to 1.1.1b-r1
  • Upgrades PHP to 7.2.14-r0
  • Upgrades psmisc to 23.2-r1
  • Upgrades sed to 4.5-r0
  • Upgrades sudo to 1.8.25_p1-r2
  • Makes log_level optional
  • Removes custom log format override
  • Rewrite add-on onto Bashio
  • Upgrades Pi-hole Core to v4.2.2
  • Upgrades Pi-hole web interface to v4.2
  • Upgrades Pi-hole FTL to v4.2.3
  • Drops legacy tag support
  • Adds support for ARMv7
  • Changes add-on URL to point to GitHub

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck

1 Like
#379

:tada: Release v3.0.1

Full Changelog

Changed

  • Fixes bug in custom virtual host function call

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck

#380

:tada: Release v3.0.2

Full Changelog

Changed

  • Fixes virtual host saving to env
  • Workaround Docker issue by reinstating legacy tags

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck

#381

Hi,

I just installed the addon Pi-Hole on my Hassio setup, and since then I have A LOT of this error showing up :

:0:0 Script error. components/system_log/__init__.py (ERROR)

Any ideas how to get rid of them ? Thanks

#382

so i have had this working in the past, but i was having an issue updating, so i have since removed pi-hole, but ever since, now when i try to install pi-hole it start the ‘circle’ like it’s attempting, then the install button flashes red, clearly meaning it failed to install. would anyone have any ideas why this would happen and possibly how to fix it?

#383

Scroll to the bottom of the page, refresh the logs, and then paste them here.

#384

there is no log there as it’s not installed… but the hass.io>system>system log shows this:

19-04-11 20:46:37 INFO (SyncWorker_10) [hassio.docker.interface] Pull image hassioaddons/pi-hole-armv7 tag 3.0.2.
19-04-11 20:46:38 ERROR (SyncWorker_10) [hassio.docker.interface] Can't install hassioaddons/pi-hole-armv7:3.0.2 -> 500 Server Error: Internal Server Error ("readlink /mnt/data/docker/overlay2/l: invalid argument").
#385

As I told you on the Discord chat already, that indicates a corrupted Docker file system. You could restore a snapshot, which in some cases, might fix that.

This is outside the scope of the add-on and impossible for us to fix (Docker issue).

#386

Quick question about this addon, is it possible to have a single device/client on my home network that is unfiltered, eg it gets all the ads and no DNS level blocking takes place?

I’d still like to leave the rest of the clients with ad blocking, but allow unrestricted access on a single device for testing and debugging.