Community Hass.io Add-on: Pi-hole

hassio-repository
hassio-addon
Tags: #<Tag:0x00007fd076ab1118> #<Tag:0x00007fd076ab0ee8>

#166

That is not a static IP. A static IP is configured in the device itself. A reserved / fixed / static DHCP lease is still DHCP and not static at all.

https://docs.resin.io/reference/resinOS/network/2.x/#setting-a-static-ip


#167

I’m unfamiliar with the issue, sorry m8. Nevertheless, Pi-hole should not influence this behavior, but if it does, it is probably because it is blocking internet requests the Nest makes.

You can see the requests a specific device makes in the Pi-hole admin panel, including if a request was blocked or not. If you find that it is blocking requests that it should not block (in order to keep the nest working), you can simply place those hosts onto the whitelist. In that case Pi-hole will no longer block those requests.


#168

Thank you very much, it´s working!!


#169

I’ll see if I can find the posts on the issue again. It used to be that a simple google search would come up with dozens of people complaining that Pi-Hole breaks things like Nest and yr.no. It breaks both of those for me.

After trying the obvious of whitelisting everything related to nest and yr, it seemed like even disabling blocking altogether didn’t help, and that people were posting something about how “pihole shouldn’t point to 127.0.0.1 but should point to 0.0.0.0” and then there was a list of commands you had to run at every reboot in order to get nest to sync up properly. Also something about the Pi having to be set up locally for a static IP rather than setting the IP as static through the router.

But for some reason, google is giving me very few results all of the sudden.

I may try reinstalling it tonight. Normally, it runs fine after installing, but at the next boot, yr and Nest fail.


#170

Hi guys!

This add-on is great!!! love it!

One question: i set this up, pointed out on my Google Wifi the ip address of the Raspberry Pi as the primary DNS. I see that PiHole blocks requests, however I only have 1 client: testwifi.here which is my Google Wifi router name. Any idea why? anyone else experiencing the same issue?

Thanks!


#171

Installed it again. It’s working great so far!

I’ll have to see how things go next time the Pi reboots. If it runs into the same issues again, I’ll be able to give you more specifics.

Thanks for the work, though!


#172

Hi,

this is because your router limitation. It acts as DNS but uses Pi-hole. So when you check for example your smartphone WiFi info it will say that DNS is your router, not Pi-Hole.
When I changed my router it allowed DHCP server to tell devices that Pi-Hole is DNS.

I hope my explanation is good. Please anyone correct me if I am missing the point.


#173

I see your point. DNS configs in the router don’t get cascaded to the devices. Limitation of Google Wifi config I guess.
Will have to leave with this. But it’s okay I guess.
Thanks!


#174

OK, so the Nest problem indeed continues to show up. My Raspberry Pi locked up, so I had to restart it, and sure enough, “Invalid Config. The following components and platforms could not be set up: Nest”

And all my results for yr.no show up as “unknown”.

I didn’t have to do anything special to reproduce this. Just install Pi-Hole on a Nest-enabled HassIO instance, and reboot it, and it breaks these components.


#175

Hi All,

I am using custom DNS 1.1.1.1 and 1.0.0.1. When I set them up they show nicely in graph … After some time (1-2 days) my dashboard graph called “Forward Destinations (integrated)” shows that all is forwarded to “local”.
did anybody experience such issue?


#176

To me this indicated you do not have a static IP set on your Hass.io machine, please be sure you have setup an static IP including an external DNS server.


#177

Not sure if it is related directly, but Pi-hole has announced it is having issues with the new Cloudflare servers.


#178

OK. Thanks. I thought I did already. I’ll have to look up how to do this, unless you happen to have a link on hand. You’ve probably explained it to a million people by now. lol


#179

The was posted like 2 days ago and has been mentioned a couple of time more. Please scroll up a little up :wink:


#180

Danggit I’m blind.

OK, looks like I’ll have to wait till I’m home again since I can’t remotely get to the boot partition


#181

OK, here’s my file

[connection]
id=my-ethernet
type=ethernet
interface-name=eth0
permissions=
secondaries=

[ethernet]
mac-address-blacklist=

[ipv4]
address1=192.168.1.2/24,192.168.1.1
dns=8.8.8.8
dns-search=
method=manual

[ipv6]
addr-gen-mode=stable-privacy
dns-search=

So it looks like I already configured it for static IP.

EDIT: I put my SD card back in my pi and started it back up. Nest and yr.no are working again for now. Interesting.


#182

:tada: Release v1.1.0

This release is exciting, at least, for me it is. I’ve been working on this for months! And for you? Well, almost nothing changed :stuck_out_tongue:

So what did change? I’ve updated the workflows of the Community Hass.io Add-ons project. Things include:

  • Replaced CircleCI and CodeClimate. We are now using GitLab CI, backed by a couple of custom servers building and testing these add-ons.
  • All add-ons are now scanned during built and release by Clair to prevent security issues in our add-ons.
  • All add-ons are constantly scanned and monitored by Anchore.io. We will be notified immediately in case of security issues occur. (Major thanks to Anchore.io for helping us out!)
  • The add-ons repository is now entirely generated and automatically synced with all the add-ons. This ensures repositories are in sync, never forgotten and releases are almost instantly.
  • The base images that these add-ons are built on are entirely revised.
  • All add-ons have been updated to follow the Docker best practices. These are checked on every code change by GitLab CI.
  • All add-ons had maintenance. All software is updated to the latest and greatest and the documentation has been revisited.
  • There are now 2 bots in place on the GitHub project. The Add-ons Assistant is helping us out with the GitHub issues and pull requests and the AddonsBot is fully active taking care of updating code across the different GitHub Repositories.
  • We now have Edge & Beta add-ons repositories available. This allows everybody to test the latest and greatest (in case you don’t care about stability that much, or just wanna help out!)
  • I’ve removed all the PayPal, Bitcoin, … buttons. If you’d like to show your appreciation, then please, just buy me a coffee.

So that’s quite a lot, right? So what changed in this specific add-on?

Full Changelog

Added

  • Adds .yamllint configuration
  • Adds Probot configuration
  • Adds initial add-on README template
  • Adds Gitlab CI

Fixed

  • Fixes Markdownlint warning in License
  • Fixes hadolint warnings
  • Fixes a yamllint warning
  • Fixes sudoers file permissions

Changed

  • Replaces Changelog with GitHub releases
  • Upgrades add-on base image to v1.4.1
  • Updates README
  • Updates Pi-hole core to v3.3.1
  • Updates PHP to v7.1.17-r0

Removed

  • Removes CodeClimate
  • Removes CircleCI
  • Removes non-existing package from Dockerfile

#183

pihole , appears to be working fine , but is not blocking any adds ,
i see this on the logs
[✗] dnsmasq: no process found
pihole-FTL: no process found

not sure if it may be the cause .


#184

I’m experiencing the same as @gnkarn and nothing is getting blocked since the update. I see traffic flowing through it, but nothing is getting blocked any longer. Is there something additional that we need to do so that we can get this working properly again?


#185

This issue @gnkarn had, was very specific. I’ve debugged it and found a possible angle.
Currently investigating the issue and at this moment it seems to be an actual bug in Pi-hole itself.

Not sure if you are experiencing the same issue, but if you are, deleting and re-installing the add-on is probably the only option currently.