Companion app stuck after login on custom Android

I am having a Android tablet based on rockchip PX30 with custom android 8.1. I installed companion app via apk method. The app opens fine , asks URL, asks API password and after that stuck on Home assistant Logo. I did installed Chrome, Opera , Android web view ( 113.0.5672.77) but didn’t seems to solve. On browser, it seems to work fine. Can someone help to debug this issue?

Rohit Soni

I had the same issue, I fixed it by clearing all the cache related to this website and bt uninstalling the service worker (don’t know which of those exactly solved the problem).

For doing this I used the Chrome devtools from my PC with USB remote debugging with Chrome on Android.

Cf Remote debug Android devices - Chrome Developers

Can’t give much more details as I did not take notes, but that’s a track to explore.

the key thing to remember when using a custom ROM is that Googles version of Android System WebView needs to be the default webview on the device. Setting the default may vary from ROM to ROM.

I couldnt get it to work on my crestron panel :frowning: Ended up having to use browser version