Component error: vaccum - Integration 'vaccum' not found

Tags: #<Tag:0x00007f3264d56f90>

Hi,

I have HA 0.118.3 installed on a Raspberry Pi and I tried to add my Roborock vacuum to HA.
I managed to retrieve the token, my vacuum has a static IP address so I think I am all good :slight_smile:
This is the first xiaomi device I am configuring on my HA.
I added the correct lines (with correct ip and token) in my configuration.yaml file

vacuum:
  - platform: xiaomi_miio
    host: 192.168.1.2
    token: YOUR_TOKEN

But I get this error when I restart my server (or when I check the config file)

Component error: vaccum - Integration 'vaccum' not found.

I don’t have the xiaomi_miio integration installed so I went to Configuration > Integration and tried to add it. I am asked this


However, I don’t have a xiaomi gateway, only a roborock. if I select the box, I am then asked to enter the IP and token of the Xiaomi Gateway. I tried to enter the robotock ip and tocken but then get an error

Unknown error occurred

According to many tutorials I have seen, I should not even have to install the xiaomi_miio integration. Do you have any idea what is wrong ?

You seem to have misspelled “vacuum” as “vaccum” somewhere. Though the config you posted is correct.

You don’t need the Miio integration.

1 Like

Oh well… I think there should be a rule like “don’t edit yaml after midnight”.

Thank you very much for your help. It was indeed that ^^

1 Like