Component not found: payload

Hello,
there is an error message? I use Hass.io on my Raspberry.
Component not found: payload
What is wrong?
Thats my configuration.yaml:

homeassistant:
  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: 52.3736
  longitude: 9.7371
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 0
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: Europe/Berlin
  # Customization file
  customize: !include customize.yaml
  customize_glob: !include customize_glob.yaml

####MQTT
mqtt:
  broker: 192.168.178.20
  port: 1883
  #client_id: home-assistant-1
  username: LedStrip
  password: LedStrip  

light:
  - platform: mqtt
    name: "Terrace Strip"
    state_topic: "home/terrace"
    command_topic: "home/terrace/set"
    effect: true
    effect_list:
      - bpm
      - candy cane  
      - confetti  
      - cyclon rainbow  
      - dots  
      - fire  
      - glitter  
      - juggle  
      - lightning
      - noise  
      - police all  
      - police one  
      - rainbow  
      - rainbow with glitter  
      - ripple  
      - sinelon  
      - solid  
      - twinkle  
    brightness: true
    flash: true
    rgb: true
    optimistic: false
    qos: 0

input_number:
  terrace_animation_speed:
    name: Terrace Animation Speed
    initial: 150
    min: 1
    max: 150
    step: 10

automation: 
  - alias: "Terrace Animation Speed"
    initial_state: True
    hide_entity: False
    trigger:
      - platform: state
        entity_id: input_number.terrace_animation_speed
    action:
      - service: mqtt.publish
        data_template:
          topic: "home/terrace/set"
payload: '{"transition":{{ trigger.to_state.state | int }}}'

####Marlon Status
input_select:
 marlon_status:
   name: Marlon Status
   options:
    - standby
    - schläft
    - beschäftigt
   initial: standby

# Enables the frontend
frontend:

# Enables configuration UI
config:

http:
  # Secrets are defined in the file secrets.yaml
  # api_password: !secret http_password
  # Uncomment this if you are using SSL/TLS, running in Docker container, etc.
  # base_url: example.duckdns.org:8123

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
updater:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically
discovery:

# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Enables support for tracking state changes over time
history:

# View all events in a logbook
logbook:

# Enables a map showing the location of tracked devices
map:

# Track the sun
sun:

# Weather prediction
sensor:
  - platform: yr

# Text to speech
tts:
  - platform: google

# Cloud
cloud:

#group: !include groups.yaml
#automation: !include automations.yaml
#script: !include scripts.yaml

####DEVICES
device_tracker:
  platform: nmap_tracker
  hosts: 192.168.178.54
  home_interval: 60
group:
####VIEWS
  default_view:
    view: yes
    icon: mdi:home
    entities:
      - group.schlafzimmer
      - group.wohnzimmer
  schlafzimmer_view:
     view: yes
     name: Schlafzimmer
     entities:
      - group.schlafzimmer
      - media_player.mein_zimmer
  wohnzimmer_view:
     view: yes
     name: Wohnzimmer
     entities:
      - group.wohnzimmer
  familie:
     view: yes
     name: Familie
     entities:
      - input_select.marlon_status
####GROUPS
  schlafzimmer:
     name: Schlafzimmer
     entities:
      - light.mein_zimmer
      - input_boolean.schlafzimmer_lockout
  wohnzimmer:
     name: Wohnzimmer
     entities:
      - input_boolean.wohnzimmer_lockout
      - light.mein_zimmer
  umgebung:
    - sun.sun
    - sensor.yr_symbol

Thx for help!

This is probably not formatted correctly.

You do not have your spacing correctly in your configuration.yaml for that line. payload needs to go within the automation > “Terrance Animation Speed” > action > data template. as it is now, it is outside the scope of the automation.

Simply put, it is a spacing error.