Components and Platforms Could not be Setup

Anybody beside me experienced any issues after upgrading to 0.103. Some of my components/integrations are not able to load or setup. That happened right after i upgraded to the latest release. I looked on the release note and I see anything related to these components:
invalidcomponent

My configurations are:

badnest:
  email: [email protected]
  password: 77777777
  region: us

climate:
  - platform: badnest
    scan_interval: 10

sensor:
  - platform: badnest
life360:
  accounts:
    - username: [email protected]
      password: cccccccc

#life360:
  driving_speed: 45
  interval_seconds: 10
  max_gps_accuracy: 50
  max_update_wait:
    minutes: 5
  show_as_state:
    - driving
    - moving
  warning_threshold: 2
  error_threshold: 3
camera:
  - platform: ring
  
sensor:
  - platform: ring
    monitored_conditions:
      - battery
      - last_ding
      - last_motion
      - volume
      
switch:
  - platform: ring
  
light:
  - platform: ring
 
## Ring Doorbell Devices
ring:
  username: [email protected]
  password: xxxxx
  scan_interval: 10

the log does not show much info.

Not a project.

I changed it.

that’s fine

If there is nothing in the log that points to an error then what I would do is start removing configuration entries until the error corrects itself then figure out why that integration is failing.

thank you for replying; i already tried that. And so far nothing work for me. I have been fighting with it since yesterday.

Ok, then try the nuclear option…

rename your existing configuration.yaml file to configuration.old. Then restart HA. After it restarts you should have a brand new clean default configuration.yaml file.

Check that the frontend comes back up and then start adding entries one by one until something breaks.

ok i will that a try. I didn’t think of that at all

I am having the exact same problem as the OP. I took your advice @finity and deleted everything from my configuration.yaml and restarted. I put ring: back in and upon reboot, got the same error. This happened immediately after 103 was installed. It’s behaving as if ring: isn’t a valid integration.ring

0.103.3 has an update to ring. I do not know whether this relates to your problem, but worthy of investigation,

Bump ring to 0.2.5 (@balloob - #30103) (ring docs)

I’ll check it out and report back to you

All good now. Thanks.

1 Like