Conbee 2 can only find 1 IKEA light but not the rest

Tags: #<Tag:0x00007f325b597a88>

I recently bought a ConBee 2 to get rid of the ridiculous 10-devices-per-controller limit from IKEA. I plugged it in to my raspberry pi 3B+ (running hassOS) using a long usb extension cord in an externally powered usb hub. I then disconnected and removed the trådfri controller, and removed the trådfri configuration from my HA config.

This is what the setup looks like now:

I have added the necessary config to the Phoscon addon, and have verified that Phoscon has set a value for Version and Firmware in the Gateway-tab (meaning it should see it). I set the “timeout for scanning for new lights” to 3 minutes and tried to pair with my trådfri lights (start scan, reset lights using on-off 6 times), but it can only find 1 of them. The weirdest bit is that I have a multitude of lights, and the lights being the closest to the stick (luminating the image above) are not found but one of my upstairs bathroom spots is (though not all).

I have been pulling my hair for a few days now and I cant understand how to fix the problem. Initially I thought that the extension cord or the usb hub might be usb3, but if that was the problem I guess that it shouldn’t be able to find any lights? Can it be that the router or Google Home is blocking signals? Anyone with any other ideas?

Having had lots of pairing problems.
Unplugging the Stick and retrying pairing dozens of times fixed it for all of my devices now.

But it is tedious and feels like luck.

Did you do it in any specific order? Like unplug between every retry, put one light at the time in pairing mode or something like that?

Some of my bulbs are really close to each other as some of the lamps contain two sockets per lamp, and am wondering if they are interfering with each other. Really disappointed that it has been so cumbersome, most people seem to get it to work immediately

Best success was unplugging the Stick, replugging it and restarting deCONZ. Then initiate search a few times before it finds stuff.

Thanks for your tips, I got the pairing fixed now! Unplugged the stick, replugged it and restarted but didn’t succeed on the first few tries. Tried to minimize the interference by moving the stick away from everything else using the usb cable. This is how ridiculous it looked, but it actually worked:

Moving the stick back to its original place now, and really hoping that it will work when sitting there. I am thinking that worst case scenario is that it will only be able to talk to one light (in the bathroom), but at least that light will be able to forward messages to other lights.