ConBee II and Zigbee2Mqtt - no worky

Anyone else having issues? This is my log output

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] socat.sh: executing... 
[10:44:42] INFO: Socat not enabled, marking service as down
[cont-init.d] socat.sh: exited 0.
[cont-init.d] zigbee2mqtt.sh: executing... 
[10:44:43] INFO: MQTT available, fetching server detail ...
[10:44:43] INFO: MQTT server settings not configured, trying to auto-discovering ...
[10:44:43] INFO: Configuring 'mqtt://core-mosquitto:1883' mqtt server
[10:44:43] INFO: MQTT credentials not configured, trying to auto-discovering ...
[10:44:43] INFO: Configuring'addons' mqtt user
[10:44:43] INFO: Previous config file found, checking backup
[10:44:43] INFO: Creating backup config in '/config/zigbee2mqtt/.configuration.yaml.bk'
[10:44:43] INFO: Adjusting Zigbee2mqtt core yaml config with add-on quirks ...
[cont-init.d] zigbee2mqtt.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[10:44:43] INFO: Handing over control to Zigbee2mqtt Core ...
> [email protected] start
> node index.js
Zigbee2MQTT:error 2022-01-06 10:45:05: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-01-06 10:45:05: Failed to start zigbee
Zigbee2MQTT:error 2022-01-06 10:45:05: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2022-01-06 10:45:05: Exiting...
Zigbee2MQTT:error 2022-01-06 10:45:05: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:102:27)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:123:29)
    at Zigbee.start (/app/lib/zigbee.ts:58:27)
    at Controller.start (/app/lib/controller.ts:100:27)
    at start (/app/index.js:97:5)
[10:45:05] INFO: Handing over control to Zigbee2mqtt Core ...
> [email protected] start
> node index.js

Works here.

How are you installed? HAOS, Supervised, etc? What hardware are you running on?

Has it worked before and this is new or is this a first install?

Thanks for replying Nathan. I am running HAOS on an HP Elite G800 DM, i5 5400 series, with 250 Gb SSD 16 Gb. This is a brand new install. I have two devices that I want to connect currently. I have one connected atm under ZHA, but that is not optimum for me and would like to switch over to Z2M.

Dit you put the “adapter: deconz”-part in the config?

Should read:
serial:
port: /dev/ttyACM0 (or wherever you find it)
adapter: deconz

1 Like

how did you mount it in your docker-compose.yaml?
by-id is better

If its a new install make sure you have the deconz line in your configuration in addition to your adapter port or it wont initialize.

I did, but no joy. I can post those results as well. I took it back out. But here is the log for that.

[11:02:49] INFO: MQTT available, fetching server detail ...
[11:02:49] INFO: MQTT server settings not configured, trying to auto-discovering ...
[11:02:50] INFO: Configuring 'mqtt://core-mosquitto:1883' mqtt server
[11:02:50] INFO: MQTT credentials not configured, trying to auto-discovering ...
[11:02:50] INFO: Configuring'addons' mqtt user
[11:02:50] INFO: Previous config file found, checking backup
[11:02:50] INFO: Creating backup config in '/config/zigbee2mqtt/.configuration.yaml.bk'
[11:02:50] INFO: Adjusting Zigbee2mqtt core yaml config with add-on quirks ...
[cont-init.d] zigbee2mqtt.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[11:02:50] INFO: Handing over control to Zigbee2mqtt Core ...
> [email protected] start
> node index.js
CREATED DECONZ ADAPTER
Zigbee2MQTT:error 2022-01-06 11:03:02: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-01-06 11:03:02: Failed to start zigbee
Zigbee2MQTT:error 2022-01-06 11:03:02: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2022-01-06 11:03:02: Exiting...
Zigbee2MQTT:error 2022-01-06 11:03:02: undefined
[11:03:02] INFO: Handing over control to Zigbee2mqtt Core ...
> [email protected] start
> node index.js
CREATED DECONZ ADAPTER
Zigbee2MQTT:error 2022-01-06 11:03:13: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-01-06 11:03:13: Failed to start zigbee
Zigbee2MQTT:error 2022-01-06 11:03:13: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2022-01-06 11:03:13: Exiting...
Zigbee2MQTT:error 2022-01-06 11:03:13: undefined
[11:03:13] INFO: Handing over control to Zigbee2mqtt Core ...
> [email protected] start
> node index.js

Well, you definitely have the deconz part of the config correct now - it knows its a phosconn adapter and is looking for it. But it cant locate it. So, then. What port is your device on? On Supervised i just look at the device list on the host and pop the stick in a few times to see what new port shows up, then use the device by-id port I find…

Nathan, that may be my issue. I have had an issue locating it. Here is my dmesg output and I do have ttyACM0 in my /dev/ folder.
dmesg output

Go to /dev/serial/by-id and issue “ls -l”, post the output here

Well, my HP only has USB 3.0 ports. I did change ports but the same result.

here you go.

And how does your config part look like?
I did have issues with zigbee2mqtt, but my error was bit different. It gave me error " SRSP - SYS - ping after 6000ms"
Also stupid question but - did you remove the adapter from ZHA (possibly restarted OS after) to make sure adapter is not used by ZHA?

1 Like

not a stupid question at all. I disabled ZHA prior to starting up Z2M. Here is my config.

data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
mqtt:
  base_topic: zigbee2mqtt
serial:
  port: >-
    /dev/serial/by-id/dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2464899-if00
  adapter: deconz
advanced:
  log_level: warn
  pan_id: 6754
  channel: 11
  network_key:
    - 24
    - 3
    - 16
    - 7
    - 254
    - 11
    - 44
    - 15
    - 0
    - 69
    - 4
    - 88
    - 188
    - 103
    - 127
    - 139
  availability_blocklist: []
  availability_passlist: []
  zigbee_herdsman_debug: true
device_options: {}
blocklist: []
passlist: []
queue: {}
frontend:
  port: 8099
experimental: {}
availability: false
socat:
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: '-d -d'
  log: false

Then I am afraid I don’t know. Your config looks exactly like mine. As I mentioned, I had error which you had initially before you added the “adapter: deconz” part.
I guess you have tried the obvious - using different USB port, remove extension cable if you are using it, restarting the host completely, etc.?
I would also give it a shot and install the edge version of Zigbee2MQTT? Save config, uninstall current, restart, install edge, restore config? Ideally, I would make sure ZHA is not only disabled, but also uninstalled? If you can do it of course.

I appreciate your efforts. I really do… For now I am sticking with ZHA as it seems stable.