Configuration telegram.yaml

Hi,
I’m trying to create a configuration to use telegram.
Therefore I created a telegram.yaml:

telegram_bot:
  - platform: broadcast
    api_key: 123456789:AABhas-AHzQrdxHJoPJ7XRkLnIbZOPI3q-4
    allowed_chat_ids:
    - 12345678

But HA shows me this in the log:

Logger: homeassistant.setup
Source: components/telegram_bot/__init__.py:339
First occurred: 14:30:29 (1 occurrences)
Last logged: 14:30:29
Error during setup of component telegram_bot

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/setup.py", line 256, in _async_setup_component
    result = await task
  File "/usr/src/homeassistant/homeassistant/components/telegram_bot/__init__.py", line 339, in async_setup
    if not config[DOMAIN]:
KeyError: 'telegram_bot'


I copied the API-key from an other configuration, so I assume, it’s not wrong.
Thank you for any help.
Regards
Uli

How did you include telegram.yaml.

If you did

telegram_bot: !include telegram.yaml

then you need to remove telegram_bot: from telegram.yaml so that it’s just

- platform: broadcast
  api_key: 123456789:AABhas-AHzQrdxHJoPJ7XRkLnIbZOPI3q-4
  allowed_chat_ids:
  - 12345678

I included telegram.yaml by configuring the configuration.yaml.
I added this line:

telegram: !include telegram.yaml

this part

- platform: broadcast
  api_key: 123456789:AABhas-AHzQrdxHJoPJ7XRkLnIbZOPI3q-4
  allowed_chat_ids:
  - 12345678

is stored in telegram.yaml

now, I get other failure messages:

 Logger: homeassistant.setup
Source: setup.py:205
First occurred: 21:00:30 (1 occurrences)
Last logged: 21:00:30
Setup failed for telegram: (DependencyError(...), 'Could not setup dependencies: telegram_bot')

and



Logger: homeassistant.setup
Source: components/telegram_bot/__init__.py:339
First occurred: 21:00:30 (1 occurrences)
Last logged: 21:00:30
Error during setup of component telegram_bot

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/setup.py", line 256, in _async_setup_component
    result = await task
  File "/usr/src/homeassistant/homeassistant/components/telegram_bot/__init__.py", line 339, in async_setup
    if not config[DOMAIN]:
KeyError: 'telegram_bot'