Home Assistant Community

Configurator Addon 3.0 on 0.91.2 - no config and port

#1

(topic withdrawn by author, will be automatically deleted in 24 hours unless flagged)

0 Likes

#2

Hi all

I had to update to 0.91.2 from 0.91.0 to have Configurator 3.0 to install.

But now the Config field and Network host filed are empty and even if I copy from the doc page and save it does not remain.

I’m on Hassio installed in docker on Ubuntu using this to install

curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install" | bash -s

I’ve tried to uninstall and reinstall the addon, but no change

Any advice?

Thanks

0 Likes

#3

same problem here using HassOS . Rolled backed to 2.1

0 Likes

#4

How did you roll back to 2.1?

0 Likes

#5

Same here. I had to restore Configurator from backup.

1 Like

#6

Thanks, rolled back from last snapshot.

0 Likes

#7

Hi,

Have you tried open configurator from web ui on addon page it is working for me.

I do not know how to change the left side panel wrench Configurator to work. I made proper url but I and up with two side panels opened at once;
My yaml code for it is:

panel_iframe:
configurator:
title: Configurator
icon: mdi:wrench
url: http://192.168.0.250:8123/hassio/ingress/core_configurator

Any suggestion, please?

0 Likes

#8

Yes, it’s working in both methods you’ve described.

But since the Config does not maintain the settings, I cannot set username and password.
I don’t know if this is specification for the new 3.0 version…

In any case I’ve opened an issue on Github

0 Likes

#9

I don’t mean to be rude but did you read the thread? Daniel posted that the new version does not need most of those options and it uses the HA user for auth!

0 Likes

#10

Yes this is my problem. I need the new url and am unable to define a port number in the settings . The configuration page settings no longer work for embedding the url

0 Likes

#11

I was looking at any changes in the Github page, but probably I haven’t seen.
For example on the first page, regarding tha panel_iframe, there is the old way of configuring, not anymore valid in v 3.0

I was not able to find the Configurator Addon thread here… :pensive:

0 Likes

#12

Hmm, all my config went through with upgrade, I read somewhere when I panicked and tried to find url, that config is not necessary now. When you open web ui in a browser you can see all url ports etc. I mage my hassio via docker not by burning image on sdcard.

0 Likes

#13

Had the same problem. Neither was I able to open the Configurator by using the 3218 port nor by using the “open web ui” button in the Configurator menu. Reinstalling the addon version 3.0 fixed the problem for me. [Hassio 0.91.2]

0 Likes

#14
0 Likes

#15

I was looking for Configurator or Configurator Addon, but if the name os different from the Addon name it’s not so easy to find.

Thanks

0 Likes

#16

Yeah you’re right… it was a little hidden.

1 Like

#17

This fixed it for me iframe now working

thanks @warcanoid

1 Like

#18

God i’m never going to get any work done now! I can do Lovelace and yaml.

0 Likes

#19

The proper http address can be found as well inn Configurator log on addon page. Easy.

So to sum up.

  1. Config is no longer necessary my looks like:

{ "dirsfirst": false, "enforce_basepath": false }

  1. Proper iframe panel looks somehow:

    panel_iframe:
    configurator:
    title: Configurator
    icon: mdi:wrench
    url: http://192.168.0.250:8123/api/hassio_ingress/4KUX4hqGAFS7rIpL........8jFibZF........./
    

This is for noobs as myself who spent 3hrs to worked out this stuff, but it was worth it I have learn a few things ;-).

3 Likes

#20

Thank you! I was struggeling with the iframe url as well.

EDIT actually, the ingress key in the url, expires. So I guess a differnt url needs to be used for iframe…

0 Likes