Configure hassio supervisor port

I am trying to run hassio via docker on my synology box, and I can successfully start the supervisor container and have it start the home assistant container, but I then run into problems with home assistant not being able to communicate with the supervisor

I managed to figure out that it’s because the supervisor is hardcoded to run the http service on port 80 and as far as I can see there is no way to configure this port either with a config option to the container or in the config file for the supervisor or home assistant

On synology port 80 is used by the nas, so I have to run the supervisor on a different port.

Am I missing something and is this possible? or is there any plans to add support for configuring the listener for the supervisor?