Connecting to Arlo using Asynchronous Arlo Integration (aarlo)

I started out with the Arlo integration (arlo), but was not successful. When I tried to log into the Arlo website, I noticed it tried to do two factor authentication using my mobile app. Then I went to the Asynchronous Arlo integration (aarlo), but did not set up the tfa parameters. Are these required?

I got the following errors:

  • Setup of aarlo is taking longer than 300 seconds. Startup will proceed without waiting any longer
  • request-error=CloudflareChallengeError
  • imap connection failed[Errno -2] Name does not resolve
  • unable to connect to Arlo: attempt=23,sleep=300,error=authentication failed
  • unable to connect to Arlo: attempt=25,sleep=300,error=2fa startup failed

Can anyone clarify how to authenticate against the Arlo API?

I know this is an old topic, but seemed appropriate to update here after I started digging into adding this into HA. Arlo/Netgear insists on 2FA for all accounts. It seems there may be a few, older accounts where it’s not enabled, but I’m betting they’ve taken care of that too.

Aarlo (Asynchronous Arlo) is another method I started looking into, but definitely a hack. It works by checking your email account (you provide the server and login credentials) and fetching the recent email that will have your 2FA information and entering it there. I’ve yet to try this, but may be an option for you. Verification must be via email, regardless.

What really needs to happen is for Arlo to provide a means of creating an app password to allow login by Arlo or AArlo.